summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyrqlite')
-rw-r--r--dev-python/pyrqlite/Manifest4
-rw-r--r--dev-python/pyrqlite/metadata.xml3
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.1.1.ebuild28
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.2.2.ebuild30
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.2.3.ebuild30
5 files changed, 64 insertions, 31 deletions
diff --git a/dev-python/pyrqlite/Manifest b/dev-python/pyrqlite/Manifest
index b8d16d384448..fe7ae7e95276 100644
--- a/dev-python/pyrqlite/Manifest
+++ b/dev-python/pyrqlite/Manifest
@@ -1,2 +1,2 @@
-DIST pyrqlite-2.1.1-test_cPragmaTableInfo.patch 2601 BLAKE2B 43dce906dea12d6d503ac589990c4688f07cf4186b6b4641534e50aa77e5dacd4f9f286d7707451bc843fb429fec4cdfb887a4922fa48aa9b7d7757bc1ff55bc SHA512 67c8593fd8a437011f9579e6a469323f60a70634469eb42d96b22f3997e48eab42d102013cbf300616fa23e2a0e64e1a0c4b4d7fdd1346402abd34255b252d85
-DIST pyrqlite-2.1.1.tar.gz 19538 BLAKE2B fba6caa68eb6d806ea807d40f36edafb0872e724a087cdb7736f79699692d0d492e05a8a7407467f92ec8e30df4a6ea1ed44bc12bec35ffc4753878335fa4275 SHA512 9fc404a480f42592ebbedef82f748707741e28de199be9381680db506dac4e3ce757d1058874ca06cf8f0dd1ec0e7b6411a4585f332a9fe7d8977071e492bd31
+DIST pyrqlite-2.2.2.gh.tar.gz 21302 BLAKE2B 8a16155287f4a4698ca63d4643c9fde0dbf4fc8238b4259f194b66a30846bab9b6420df0cc8049b2ea16d8ffdcd8c99f2b7e49a135af458e2b239b52e3ac4f5b SHA512 6faf6d5b1a264a85247ee5a790bc4e718d0632ee4d4bcd16aed2bce65216f23c0cb44d7c367ae73874bdb618d9c56bbefdaeebb40322f228e0ee50d78e03b91b
+DIST pyrqlite-2.2.3.gh.tar.gz 21554 BLAKE2B 1a3c09eaee20a19ab06a4f91a5b12659eafe425f796599ef9abf85f99563a62b40f1f82488611e0bbd1fb18853e2b1e310ecd7f94cb89f5840e34c51a4bd42ef SHA512 063a9072846c31fd34ea5261fe97f1023a95122c39c58292c7ab08ba148e01ab5001adda28c2856f0e29b67be553a8bae011d274edfdd3028aacd22179d309d7
diff --git a/dev-python/pyrqlite/metadata.xml b/dev-python/pyrqlite/metadata.xml
index 9e5d47caf7e6..020d9ac0943d 100644
--- a/dev-python/pyrqlite/metadata.xml
+++ b/dev-python/pyrqlite/metadata.xml
@@ -5,6 +5,7 @@
<email>zmedico@gentoo.org</email>
</maintainer>
<upstream>
- <remote-id type="github">rqlite/pyrqlite</remote-id>
+ <remote-id type="github">rqlite/pyrqlite</remote-id>
+ <remote-id type="pypi">pyrqlite</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild b/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild
deleted file mode 100644
index 4d08827d5414..000000000000
--- a/dev-python/pyrqlite/pyrqlite-2.1.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python client for rqlite"
-HOMEPAGE="https://github.com/rqlite/pyrqlite"
-SRC_URI="https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/rqlite/pyrqlite/pull/42.patch -> ${P}-test_cPragmaTableInfo.patch"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="test? ( >=dev-db/rqlite-6.7.0 )"
-RESTRICT+=" !test? ( test )"
-
-PATCHES=("${DISTDIR}/${P}-test_cPragmaTableInfo.patch")
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild b/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild
new file mode 100644
index 000000000000..ec12bed1b7aa
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="
+ https://github.com/rqlite/pyrqlite/
+ https://pypi.org/project/pyrqlite/
+"
+SRC_URI="
+ https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-db/rqlite-6.7.0
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pyrqlite/pyrqlite-2.2.3.ebuild b/dev-python/pyrqlite/pyrqlite-2.2.3.ebuild
new file mode 100644
index 000000000000..ec12bed1b7aa
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="
+ https://github.com/rqlite/pyrqlite/
+ https://pypi.org/project/pyrqlite/
+"
+SRC_URI="
+ https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-db/rqlite-6.7.0
+ )
+"
+
+distutils_enable_tests pytest