summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-ordering/pytest-ordering-0.6.ebuild')
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
deleted file mode 100644
index 25ef67eebc14..000000000000
--- a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to run your tests in a specific order"
-HOMEPAGE="
- https://github.com/ftobia/pytest-ordering/
- https://pypi.org/project/pytest-ordering/
-"
-SRC_URI="https://github.com/ftobia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-pytest-6.patch"
-)
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs/source
-
-python_prepare_all() {
- # TypeError: `args` parameter expected to be a list or tuple of strings, got: '--markers' (type: <class 'str'>)
- sed -i -e 's:test_run_marker_registered:_&:' \
- tests/test_ordering.py || die
-
- distutils-r1_python_prepare_all
-}