summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-ordering')
-rw-r--r--dev-python/pytest-ordering/Manifest2
-rw-r--r--dev-python/pytest-ordering/files/pytest-ordering-0.6-marks.patch56
-rw-r--r--dev-python/pytest-ordering/metadata.xml5
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6-r1.ebuild35
-rw-r--r--dev-python/pytest-ordering/pytest-ordering-0.6.ebuild36
5 files changed, 93 insertions, 41 deletions
diff --git a/dev-python/pytest-ordering/Manifest b/dev-python/pytest-ordering/Manifest
index 0036ecd18b92..70e461ee5ebf 100644
--- a/dev-python/pytest-ordering/Manifest
+++ b/dev-python/pytest-ordering/Manifest
@@ -1 +1 @@
-DIST pytest-ordering-0.6.tar.gz 11046 BLAKE2B 468ae5f04029b96ed3058b7f429aec0aaf96092453b229c3de5eab174702af2c1a9fe83171c68d282c4a144b3dd736daf9ed87b9e139a7bd175114f504049ebc SHA512 fd3aec83914f64d1295e1a1bf3fdc580c6824a749a1da8cebae275fef940d6ed6e5dcafad321d94f504a153e13e298b6544dc3c2db716a6b25d3148c2365fe15
+DIST pytest-ordering-0.6.gh.tar.gz 11046 BLAKE2B 468ae5f04029b96ed3058b7f429aec0aaf96092453b229c3de5eab174702af2c1a9fe83171c68d282c4a144b3dd736daf9ed87b9e139a7bd175114f504049ebc SHA512 fd3aec83914f64d1295e1a1bf3fdc580c6824a749a1da8cebae275fef940d6ed6e5dcafad321d94f504a153e13e298b6544dc3c2db716a6b25d3148c2365fe15
diff --git a/dev-python/pytest-ordering/files/pytest-ordering-0.6-marks.patch b/dev-python/pytest-ordering/files/pytest-ordering-0.6-marks.patch
new file mode 100644
index 000000000000..16712166325c
--- /dev/null
+++ b/dev-python/pytest-ordering/files/pytest-ordering-0.6-marks.patch
@@ -0,0 +1,56 @@
+From 6de05faa7d399a3f0f99b33b75747d39adb1f535 Mon Sep 17 00:00:00 2001
+From: Brian Maissy <brian.maissy@gmail.com>
+Date: Fri, 31 May 2019 03:03:38 +0300
+Subject: [PATCH] register marks, document python and pytest dependencies, and
+ test the full matrix with tox and travis
+
+minimized from:
+https://github.com/ftobia/pytest-ordering/commit/6de05faa7d399a3f0f99b33b75747d39adb1f535
+
+diff --git a/pytest_ordering/__init__.py b/pytest_ordering/__init__.py
+index 0cca91d..c8eb64a 100644
+--- a/pytest_ordering/__init__.py
++++ b/pytest_ordering/__init__.py
+@@ -28,13 +28,23 @@
+ def pytest_configure(config):
+ """Register the "run" marker."""
+
++ provided_by_pytest_ordering = (
++ 'Provided by pytest-ordering. '
++ 'See also: http://pytest-ordering.readthedocs.org/'
++ )
++
+ config_line = (
+ 'run: specify ordering information for when tests should run '
+- 'in relation to one another. Provided by pytest-ordering. '
+- 'See also: http://pytest-ordering.readthedocs.org/'
++ 'in relation to one another. ' + provided_by_pytest_ordering
+ )
+ config.addinivalue_line('markers', config_line)
+
++ for mark_name in orders_map.keys():
++ config_line = '{}: run test {}. {}'.format(mark_name,
++ mark_name.replace('_', ' '),
++ provided_by_pytest_ordering)
++ config.addinivalue_line('markers', config_line)
++
+
+ def pytest_collection_modifyitems(session, config, items):
+ grouped_items = {}
+diff --git a/tests/test_ordering.py b/tests/test_ordering.py
+index 12f4689..dd703ab 100644
+--- a/tests/test_ordering.py
++++ b/tests/test_ordering.py
+@@ -268,7 +268,10 @@ def test_5(self): pass
+ assert item_names_for(tests_content) == ['test_3', 'test_4', 'test_5', 'test_1', 'test_2']
+
+
+-def test_run_marker_registered(capsys):
+- pytest.main('--markers')
++def test_markers_registered(capsys):
++ pytest.main(['--markers'])
+ out, err = capsys.readouterr()
+ assert '@pytest.mark.run' in out
++ assert '@pytest.mark.first' in out
++ assert '@pytest.mark.last' in out
++ assert out.count('Provided by pytest-ordering') == 17
diff --git a/dev-python/pytest-ordering/metadata.xml b/dev-python/pytest-ordering/metadata.xml
index 256ad6903f29..24ed22f81900 100644
--- a/dev-python/pytest-ordering/metadata.xml
+++ b/dev-python/pytest-ordering/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>andrewammerlaan@gentoo.org</email>
- <name>Andrew Ammerlaan</name>
- </maintainer>
+ <!-- maintainer-needed -->
<stabilize-allarches/>
<upstream>
<remote-id type="github">ftobia/pytest-ordering</remote-id>
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6-r1.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6-r1.ebuild
new file mode 100644
index 000000000000..b2f03be453d3
--- /dev/null
+++ b/dev-python/pytest-ordering/pytest-ordering-0.6-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/ftobia/pytest-ordering/
+ https://pypi.org/project/pytest-ordering/
+"
+SRC_URI="
+ https://github.com/ftobia/pytest-ordering/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-pytest-6.patch"
+ "${FILESDIR}/${P}-marks.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source
diff --git a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild b/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
deleted file mode 100644
index 25ef67eebc14..000000000000
--- a/dev-python/pytest-ordering/pytest-ordering-0.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to run your tests in a specific order"
-HOMEPAGE="
- https://github.com/ftobia/pytest-ordering/
- https://pypi.org/project/pytest-ordering/
-"
-SRC_URI="https://github.com/ftobia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 sparc x86"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-pytest-6.patch"
-)
-
-distutils_enable_tests --install pytest
-distutils_enable_sphinx docs/source
-
-python_prepare_all() {
- # TypeError: `args` parameter expected to be a list or tuple of strings, got: '--markers' (type: <class 'str'>)
- sed -i -e 's:test_run_marker_registered:_&:' \
- tests/test_ordering.py || die
-
- distutils-r1_python_prepare_all
-}