summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-faulthandler/Manifest2
-rw-r--r--dev-python/pytest-faulthandler/metadata.xml12
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild36
-rw-r--r--dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild20
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pytest-faulthandler/Manifest b/dev-python/pytest-faulthandler/Manifest
new file mode 100644
index 000000000000..3b5372a25474
--- /dev/null
+++ b/dev-python/pytest-faulthandler/Manifest
@@ -0,0 +1,2 @@
+DIST pytest-faulthandler-1.6.0.tar.gz 6656 BLAKE2B 0fe66827e09c6b566ac6a9aa3fd4da03f0f5c4ea1e8601b16ed1a211c33150bcc0eaac5b47786040f571ceb266300bcb5142e2a8d977aeb69f89bd0ecefec4c3 SHA512 23146b1c0965e66ac201cae82192f3833daad2563f2177d916050df14b532a3eb78f2dd3b888cec3d28121b334ee86c9b762c5aadb8fb624c9a4288fbad693a5
+DIST pytest-faulthandler-2.0.1.tar.gz 3629 BLAKE2B f66b6989673b179b3ad3f583b9e7b9615b08e1e062f06969f37bd8a9a57e58bd0207544b0c11aa4a9d03f4db40a125bbbe1924160b2bdcb2c0c589de07281570 SHA512 184b4228693db0f15fdcf250f09c3ee9ef4767e744af9000ec46876f0c68e17434a6d1e25c7d59f610b2baa659d7af5a784cbf0e5e29b105f48d50d00cb1a7ca
diff --git a/dev-python/pytest-faulthandler/metadata.xml b/dev-python/pytest-faulthandler/metadata.xml
new file mode 100644
index 000000000000..d22e99d73577
--- /dev/null
+++ b/dev-python/pytest-faulthandler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
new file mode 100644
index 000000000000..5033fc34123b
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ >=dev-python/pytest-4.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild
new file mode 100644
index 000000000000..38021a87f44e
--- /dev/null
+++ b/dev-python/pytest-faulthandler/pytest-faulthandler-2.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that activates the fault handler module for tests"
+HOMEPAGE="https://github.com/pytest-dev/pytest-faulthandler"
+SRC_URI="https://github.com/pytest-dev/pytest-faulthandler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-5.0[${PYTHON_USEDEP}]
+"