summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/control_toolbox/control_toolbox-1.16.0.ebuild')
-rw-r--r--dev-ros/control_toolbox/control_toolbox-1.16.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/control_toolbox/control_toolbox-1.16.0.ebuild b/dev-ros/control_toolbox/control_toolbox-1.16.0.ebuild
new file mode 100644
index 000000000000..91cec2668963
--- /dev/null
+++ b/dev-ros/control_toolbox/control_toolbox-1.16.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/control_toolbox"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Modules that are useful across all controllers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure
+ dev-ros/realtime_tools
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml
+ dev-ros/control_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"