summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/map_server/map_server-1.16.0.ebuild')
-rw-r--r--dev-ros/map_server/map_server-1.16.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/map_server/map_server-1.16.0.ebuild b/dev-ros/map_server/map_server-1.16.0.ebuild
new file mode 100644
index 000000000000..429845481287
--- /dev/null
+++ b/dev-ros/map_server/map_server-1.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Offers map data as a ROS service"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ sci-physics/bullet:=
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ media-libs/sdl-image
+ dev-ros/tf2
+ >=dev-cpp/yaml-cpp-0.5:=
+
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest dev-ros/rospy dev-ros/rosunit )
+ virtual/pkgconfig"