summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/roscpp/files')
-rw-r--r--dev-ros/roscpp/files/boost.patch26
-rw-r--r--dev-ros/roscpp/files/boost173.patch62
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-ros/roscpp/files/boost.patch b/dev-ros/roscpp/files/boost.patch
deleted file mode 100644
index 1d509a8ab6c7..000000000000
--- a/dev-ros/roscpp/files/boost.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
-Author: Maarten de Vries <maarten@de-vri.es>
-Date: Thu Jan 31 00:58:29 2019 +0100
-
- Remove signals from find_package(Boost COMPONENTS ...) (#1580)
-
- The packages use signals2, not signals. Only boost libraries with
- compiled code should be passed to find_package(Boost COMPONENTS ...),
- and the signals2 library has always been header only.
-
- Boost 1.69 has removed the deprecated signals library, so the otherwise
- useless but harmless `signals` component now breaks the build.
-
-diff --git a/clients/roscpp/CMakeLists.txt b/clients/roscpp/CMakeLists.txt
-index a5d354ea6..8f462df2c 100644
---- a/clients/roscpp/CMakeLists.txt
-+++ b/clients/roscpp/CMakeLists.txt
-@@ -22,7 +22,7 @@ list(GET roscpp_VERSION_LIST 2 roscpp_VERSION_PATCH)
-
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/include/ros/common.h.in ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros/common.h)
-
--find_package(Boost REQUIRED COMPONENTS chrono filesystem signals system)
-+find_package(Boost REQUIRED COMPONENTS chrono filesystem system)
-
- include_directories(include ${CATKIN_DEVEL_PREFIX}/${CATKIN_GLOBAL_INCLUDE_DESTINATION}/ros ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
-
diff --git a/dev-ros/roscpp/files/boost173.patch b/dev-ros/roscpp/files/boost173.patch
deleted file mode 100644
index d31f8c8ff246..000000000000
--- a/dev-ros/roscpp/files/boost173.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-Index: roscpp/include/ros/timer_manager.h
-===================================================================
---- roscpp.orig/include/ros/timer_manager.h
-+++ roscpp/include/ros/timer_manager.h
-@@ -349,7 +349,7 @@ int32_t TimerManager<T, D, E>::add(const
- {
- boost::mutex::scoped_lock lock(waiting_mutex_);
- waiting_.push_back(info->handle);
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-@@ -416,7 +416,7 @@ void TimerManager<T, D, E>::schedule(con
-
- waiting_.push_back(info->handle);
- // waitingCompare requires a lock on the timers_mutex_
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-@@ -490,7 +490,7 @@ void TimerManager<T, D, E>::setPeriod(in
- // In this case, let next_expected be updated only in updateNext
-
- info->period = period;
-- waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, _1, _2));
-+ waiting_.sort(boost::bind(&TimerManager::waitingCompare, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- new_timer_ = true;
-Index: roscpp/src/libros/connection_manager.cpp
-===================================================================
---- roscpp.orig/src/libros/connection_manager.cpp
-+++ roscpp/src/libros/connection_manager.cpp
-@@ -66,7 +66,7 @@ void ConnectionManager::start()
- tcpserver_transport_ = boost::make_shared<TransportTCP>(&poll_manager_->getPollSet());
- if (!tcpserver_transport_->listen(network::getTCPROSPort(),
- MAX_TCPROS_CONN_QUEUE,
-- boost::bind(&ConnectionManager::tcprosAcceptConnection, this, _1)))
-+ boost::bind(&ConnectionManager::tcprosAcceptConnection, this, boost::placeholders::_1)))
- {
- ROS_FATAL("Listen on port [%d] failed", network::getTCPROSPort());
- ROS_BREAK();
-@@ -142,7 +142,7 @@ void ConnectionManager::addConnection(co
- boost::mutex::scoped_lock lock(connections_mutex_);
-
- connections_.insert(conn);
-- conn->addDropListener(boost::bind(&ConnectionManager::onConnectionDropped, this, _1));
-+ conn->addDropListener(boost::bind(&ConnectionManager::onConnectionDropped, this, boost::placeholders::_1));
- }
-
- void ConnectionManager::onConnectionDropped(const ConnectionPtr& conn)
-@@ -190,7 +190,7 @@ void ConnectionManager::tcprosAcceptConn
- ConnectionPtr conn(boost::make_shared<Connection>());
- addConnection(conn);
-
-- conn->initialize(transport, true, boost::bind(&ConnectionManager::onConnectionHeaderReceived, this, _1, _2));
-+ conn->initialize(transport, true, boost::bind(&ConnectionManager::onConnectionHeaderReceived, this, boost::placeholders::_1, boost::placeholders::_2));
- }
-
- bool ConnectionManager::onConnectionHeaderReceived(const ConnectionPtr& conn, const Header& header)