summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/Manifest1
-rw-r--r--dev-util/cscope/cscope-15.8a-r1.ebuild64
-rw-r--r--dev-util/cscope/cscope-15.9-r1.ebuild (renamed from dev-util/cscope/cscope-15.8a-r2.ebuild)19
-rw-r--r--dev-util/cscope/cscope-15.9.ebuild11
-rw-r--r--dev-util/cscope/files/cscope-15.6-darwin.patch11
-rw-r--r--dev-util/cscope/files/cscope-15.9-emacs-27.patch28
-rw-r--r--dev-util/cscope/files/cscope-15.9-pkgconfig.patch28
-rw-r--r--dev-util/cscope/metadata.xml2
8 files changed, 73 insertions, 91 deletions
diff --git a/dev-util/cscope/Manifest b/dev-util/cscope/Manifest
index 7f460cd88c2d..2cfad02c76a3 100644
--- a/dev-util/cscope/Manifest
+++ b/dev-util/cscope/Manifest
@@ -1,2 +1 @@
-DIST cscope-15.8a.tar.gz 601232 BLAKE2B 8c67311059a055af775ba3d42942a557b54c0214751d8756e6a5c19a7a271824004e72c533614015ddcb0ffa4c768f99eb736d441dc8467c5be4824cebf5c15e SHA512 bedba69820eca86420f6c975d1f267de67a457b182a3fe49720a2ae5ea48759c5b5b8db06ed5ffd85173ddf4a0f12ca722e87200dea4a2da7d43c8c711b00318
DIST cscope-15.9.tar.gz 613948 BLAKE2B 66c0c85d0db810e8cd5a286925eeb1026fa4a9e9c3a5a9decd1412188fca43f831949c231acca428b5eeb476662b7ce9f81defcda81759c18027655535b855be SHA512 f3b95da5eb5c036cd39215785990c7cce7ce7b8eda4b18e60792e70d01ffb63809ce32ace310a9aefd88e6761c1609039ccfab0e8e49f81730bc1630babbcb80
diff --git a/dev-util/cscope/cscope-15.8a-r1.ebuild b/dev-util/cscope/cscope-15.8a-r1.ebuild
deleted file mode 100644
index b1ae51bd71ef..000000000000
--- a/dev-util/cscope/cscope-15.8a-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools elisp-common toolchain-funcs
-
-DESCRIPTION="Interactively examine a C program"
-HOMEPAGE="http://cscope.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
-
-LICENSE="BSD GPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="emacs"
-
-RDEPEND=">=sys-libs/ncurses-5.2:0=
- emacs? ( >=app-editors/emacs-23.1:* )"
-DEPEND="${RDEPEND}
- sys-devel/flex
- virtual/pkgconfig
- virtual/yacc"
-
-SITEFILE="50${PN}-gentoo.el"
-
-src_prepare() {
- eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
- eapply_user
- mv configure.{in,ac} || die
- eautoreconf # prevent maintainer mode later on
-}
-
-src_compile() {
- emake CURSES_LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
- if use emacs; then
- cd "${S}"/contrib/xcscope || die
- elisp-compile *.el
- fi
-}
-
-src_install() {
- default
-
- if use emacs; then
- cd "${S}"/contrib/xcscope || die
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- dobin cscope-indexer
- fi
-
- cd "${S}"/contrib/webcscope || die
- docinto webcscope
- dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
- docinto webcscope/icons
- dodoc icons/*.gif
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-util/cscope/cscope-15.8a-r2.ebuild b/dev-util/cscope/cscope-15.9-r1.ebuild
index c47d3feaa6c8..b993af8f8e8d 100644
--- a/dev-util/cscope/cscope-15.8a-r2.ebuild
+++ b/dev-util/cscope/cscope-15.9-r1.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools elisp-common toolchain-funcs
DESCRIPTION="Interactively examine a C program"
-HOMEPAGE="http://cscope.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+HOMEPAGE="https://cscope.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/cscope/${P}.tar.gz"
LICENSE="BSD GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="emacs"
RDEPEND=">=sys-libs/ncurses-5.2:0=
emacs? ( >=app-editors/emacs-23.1:* )"
-DEPEND="${RDEPEND}
- sys-devel/flex
+DEPEND="${RDEPEND}"
+BDEPEND="app-alternatives/lex
virtual/pkgconfig
- virtual/yacc"
+ app-alternatives/yacc"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
- eapply "${FILESDIR}/${PN}-15.6-darwin.patch"
+ eapply "${FILESDIR}/${PN}-15.9-pkgconfig.patch"
+ eapply "${FILESDIR}/${PN}-15.9-emacs-27.patch"
eapply_user
mv configure.{in,ac} || die
eautoreconf # prevent maintainer mode later on
diff --git a/dev-util/cscope/cscope-15.9.ebuild b/dev-util/cscope/cscope-15.9.ebuild
index c5b4b35ef25f..09ab7c4c9b5e 100644
--- a/dev-util/cscope/cscope-15.9.ebuild
+++ b/dev-util/cscope/cscope-15.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,24 +7,25 @@ inherit autotools elisp-common toolchain-funcs
DESCRIPTION="Interactively examine a C program"
HOMEPAGE="http://cscope.sourceforge.net/"
-SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/cscope/${P}.tar.gz"
LICENSE="BSD GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="emacs"
RDEPEND=">=sys-libs/ncurses-5.2:0=
emacs? ( >=app-editors/emacs-23.1:* )"
DEPEND="${RDEPEND}"
-BDEPEND="sys-devel/flex
+BDEPEND="app-alternatives/lex
virtual/pkgconfig
- virtual/yacc"
+ app-alternatives/yacc"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
+ eapply "${FILESDIR}/${PN}-15.9-pkgconfig.patch"
eapply_user
mv configure.{in,ac} || die
eautoreconf # prevent maintainer mode later on
diff --git a/dev-util/cscope/files/cscope-15.6-darwin.patch b/dev-util/cscope/files/cscope-15.6-darwin.patch
deleted file mode 100644
index e755f3257efd..000000000000
--- a/dev-util/cscope/files/cscope-15.6-darwin.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/constants.h
-+++ b/src/constants.h
-@@ -103,7 +103,7 @@
- #define INCLUDES 8
- #define FIELDS 9
-
--#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__
-+#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__ && !__MACH__
- # define TERMINFO 0 /* no terminfo curses */
- #else
- # define TERMINFO 1
diff --git a/dev-util/cscope/files/cscope-15.9-emacs-27.patch b/dev-util/cscope/files/cscope-15.9-emacs-27.patch
new file mode 100644
index 000000000000..48cd7150176d
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-emacs-27.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/892071
+
+commit eaea31cb93ecddda69a373f83f632e1a450c3c90
+Author: Brock Zheng Techyauld Ltd <yzheng@techyauld.com>
+Date: Tue Aug 25 20:28:11 2020 +0800
+
+ emacs plugin fixup: GNU/Emacs 27.1 removes function process-kill-without-query
+
+--- a/contrib/xcscope/xcscope.el
++++ b/contrib/xcscope/xcscope.el
+@@ -2006,7 +2006,7 @@
+ (set-process-filter cscope-process cscope-filter-func)
+ (set-process-sentinel cscope-process cscope-sentinel-func)
+ (set-marker (process-mark cscope-process) (point))
+- (process-kill-without-query cscope-process)
++ (set-process-query-on-exit-flag cscope-process nil)
+ (if cscope-running-in-xemacs
+ (setq modeline-process ": Searching ..."))
+ (setq buffer-read-only t)
+@@ -2139,7 +2139,7 @@
+ cscope-indexing-script args))
+ (set-process-sentinel cscope-unix-index-process
+ 'cscope-unix-index-files-sentinel)
+- (process-kill-without-query cscope-unix-index-process)
++ (set-process-query-on-exit-flag cscope-unix-index-process nil)
+ )
+ ))
+
diff --git a/dev-util/cscope/files/cscope-15.9-pkgconfig.patch b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
new file mode 100644
index 000000000000..c031633a6559
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -18,6 +18,7 @@ if test "x$LEX" = "xlex" ; then AC_DEFINE(USING_LEX, 1,
+ [Define this if the scanner is run through lex, not flex])
+ fi
+ AC_PROG_YACC
++PKG_PROG_PKG_CONFIG
+
+ AC_SYS_LARGEFILE
+
+@@ -361,7 +362,7 @@ dnl Check for a GNOME installation
+ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=false
+ AC_CHECK_PROG(gnome1, gnome-config, true)
+- AC_CHECK_PROG(gnome2, pkg-config, true)
++ AC_CHECK_PROG(gnome2, $PKG_CONFIG, true)
+
+ if test x$gnome1 = xtrue; then
+ has_gnome=true
+@@ -371,7 +372,7 @@ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=true
+ fi
+
+- AM_CONDITIONAL(USING_GNOME2, pkg-config --exists gtk+-2.0)
++ AM_CONDITIONAL(USING_GNOME2, $PKG_CONFIG --exists gtk+-2.0)
+ AM_CONDITIONAL(HAS_GNOME, test "$has_gnome" = true)
+ AM_CONDITIONAL(GNOME_LINUX, test "$host_os" = Linux)
+ ])
diff --git a/dev-util/cscope/metadata.xml b/dev-util/cscope/metadata.xml
index d474ab0ab2b1..08e778f021d2 100644
--- a/dev-util/cscope/metadata.xml
+++ b/dev-util/cscope/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>vim@gentoo.org</email>