summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cscope/files/cscope-15.9-pkgconfig.patch')
-rw-r--r--dev-util/cscope/files/cscope-15.9-pkgconfig.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/cscope/files/cscope-15.9-pkgconfig.patch b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
new file mode 100644
index 000000000000..c031633a6559
--- /dev/null
+++ b/dev-util/cscope/files/cscope-15.9-pkgconfig.patch
@@ -0,0 +1,28 @@
+--- a/configure.in
++++ b/configure.in
+@@ -18,6 +18,7 @@ if test "x$LEX" = "xlex" ; then AC_DEFINE(USING_LEX, 1,
+ [Define this if the scanner is run through lex, not flex])
+ fi
+ AC_PROG_YACC
++PKG_PROG_PKG_CONFIG
+
+ AC_SYS_LARGEFILE
+
+@@ -361,7 +362,7 @@ dnl Check for a GNOME installation
+ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=false
+ AC_CHECK_PROG(gnome1, gnome-config, true)
+- AC_CHECK_PROG(gnome2, pkg-config, true)
++ AC_CHECK_PROG(gnome2, $PKG_CONFIG, true)
+
+ if test x$gnome1 = xtrue; then
+ has_gnome=true
+@@ -371,7 +372,7 @@ AC_DEFUN([AC_CHECK_GNOME],[
+ has_gnome=true
+ fi
+
+- AM_CONDITIONAL(USING_GNOME2, pkg-config --exists gtk+-2.0)
++ AM_CONDITIONAL(USING_GNOME2, $PKG_CONFIG --exists gtk+-2.0)
+ AM_CONDITIONAL(HAS_GNOME, test "$has_gnome" = true)
+ AM_CONDITIONAL(GNOME_LINUX, test "$host_os" = Linux)
+ ])