summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/yamllint/yamllint-1.32.0.ebuild')
-rw-r--r--dev-util/yamllint/yamllint-1.32.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.32.0.ebuild b/dev-util/yamllint/yamllint-1.32.0.ebuild
new file mode 100644
index 000000000000..695351cc4742
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.32.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest