summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/yamllint')
-rw-r--r--dev-util/yamllint/Manifest4
-rw-r--r--dev-util/yamllint/yamllint-1.32.0.ebuild (renamed from dev-util/yamllint/yamllint-1.27.1.ebuild)9
-rw-r--r--dev-util/yamllint/yamllint-1.33.0-r1.ebuild23
-rw-r--r--dev-util/yamllint/yamllint-1.35.1.ebuild23
4 files changed, 53 insertions, 6 deletions
diff --git a/dev-util/yamllint/Manifest b/dev-util/yamllint/Manifest
index d73b6b3007f0..dd61bb414c84 100644
--- a/dev-util/yamllint/Manifest
+++ b/dev-util/yamllint/Manifest
@@ -1 +1,3 @@
-DIST yamllint-1.27.1.tar.gz 129052 BLAKE2B 37021bd577384821b75ddd747f1dd3c4261317582d42179e0731214cb67f79bf9302c34acaa721440edb118ef8900cc2952d1f8e441def9e3143b57e03af87bd SHA512 c00fcb5da35f79b0f877f1b8c3e5f1ff8c5d161dd795d3a2657e44e27d8b943961984bf15c294be263e00bf9dfcaf3dbf16ef8fd7354bedc8ed92e3e24ce4baf
+DIST yamllint-1.32.0.tar.gz 130041 BLAKE2B 68dc6fb6b0f030a32d824a09fcb122de6d0f86cfa2b1325161395c7f6277cb074fc2a4c282c56a0bfd598ddf3efd56f4c8dd497546ea75cce5bdb3c7aa5f7431 SHA512 8a7ecb22c5c6705fe85091923b0f1ef9c7df702ad35ffaeb5db94262c32a294c59c9d1a737d6ca280c16a054ad8d3f3210b31acdd69cc73d4fa259c9631cc322
+DIST yamllint-1.33.0.tar.gz 130357 BLAKE2B 9747c6327d5643c250f0824a5dde6290fc8e5ed08b0269e59387cefc7a9b1cf78343574c7ebdecfd0294275a0c837e4ef3e445cb5db7becd65120d3fe860e998 SHA512 99aa8f1a85da891d697c78f998af9bd656759fa218b7c058d6b990b01a6a939d78ecb2938ef5211700e5c5a1b0f884e77ba68510d9e790d7f77e3185e2f4fb52
+DIST yamllint-1.35.1.tar.gz 134583 BLAKE2B 8ab5a1c36aa40133be5f6527ab0c894027d35e608338fe603baf8be6e40de92de09be7558cbfa084be70755771b5b43d9b9765906509358f80578f0db3681be1 SHA512 c174b217da5b1efa56651a29fc92f91699c15d6c3c27f6cd4bd71ea8d55f59748b3006ed73678fa1b635b6d092230d8d5cd56b4bb63894931e7357a2c4f84a98
diff --git a/dev-util/yamllint/yamllint-1.27.1.ebuild b/dev-util/yamllint/yamllint-1.32.0.ebuild
index 8c9945125f8e..695351cc4742 100644
--- a/dev-util/yamllint/yamllint-1.27.1.ebuild
+++ b/dev-util/yamllint/yamllint-1.32.0.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="A linter for YAML files"
HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 ~riscv"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/dev-util/yamllint/yamllint-1.33.0-r1.ebuild b/dev-util/yamllint/yamllint-1.33.0-r1.ebuild
new file mode 100644
index 000000000000..04ad8f3bce38
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.33.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-util/yamllint/yamllint-1.35.1.ebuild b/dev-util/yamllint/yamllint-1.35.1.ebuild
new file mode 100644
index 000000000000..04ad8f3bce38
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.35.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest