summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/manaplus/manaplus-9999.ebuild')
-rw-r--r--games-rpg/manaplus/manaplus-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-rpg/manaplus/manaplus-9999.ebuild b/games-rpg/manaplus/manaplus-9999.ebuild
index 4682afacd0d7..c93acd1164d1 100644
--- a/games-rpg/manaplus/manaplus-9999.ebuild
+++ b/games-rpg/manaplus/manaplus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,6 +57,7 @@ DEPEND="${RDEPEND}
src_prepare() {
default
+
if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
@@ -73,7 +74,8 @@ src_configure() {
$(use_with sdl2)
$(use_enable test unittests)
)
- CONFIG_SHELL="/bin/bash" econf "${myeconfargs[@]}"
+
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
}
src_install() {
@@ -95,7 +97,3 @@ src_install() {
dosym ${srcpath}/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/mplus-1p-regular.ttf
dosym ${srcpath}/wqy-microhei/wqy-microhei.ttc "${destpath}"/wqy-microhei.ttf
}
-
-src_test() {
- make check
-}