summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/nml/nml-0.4.4.ebuild')
-rw-r--r--games-util/nml/nml-0.4.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-util/nml/nml-0.4.4.ebuild b/games-util/nml/nml-0.4.4.ebuild
new file mode 100644
index 000000000000..56979b798abc
--- /dev/null
+++ b/games-util/nml/nml-0.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${P}-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}