summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util')
-rw-r--r--games-util/nml/Manifest1
-rw-r--r--games-util/nml/files/nml-0.4.4-pillow3.patch11
-rw-r--r--games-util/nml/nml-0.4.4.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/games-util/nml/Manifest b/games-util/nml/Manifest
index d546ef6b31a0..d099670107e3 100644
--- a/games-util/nml/Manifest
+++ b/games-util/nml/Manifest
@@ -1 +1,2 @@
DIST nml-0.4.2.tar.gz 377834 SHA256 eb4c2107682f14c58c5fbffc5f26c206fd3c8fc6972a3e28478e3e7f2bb773d7 SHA512 0d9c9f1de91cd91962aeacc0e5c59b351a2e4729f97d7fc2eb49f6d6487c1e1a7a98fb8f793689520c6e828fd6cdf39e952f13d0dc2f198234e3e6ad47fe6d8b WHIRLPOOL d4d994125c04c53528ae4cf9e3ca4643d2ef1e71636453404196b200a275649b2846683406bbae6f76e98573ea92962c23e295adeba3f6086026c0b8fd676c75
+DIST nml-0.4.4.tar.gz 377998 SHA256 af66146b5cf7e0a06a80ae2882d6899faf4ed27b41ce4c8aca934b8f8ba66972 SHA512 fd7b8d7abfc8b5ea694eedf00bbc4069a82de942178a58ec05e9d3efe7c8663103ffb6b98f7614ce165eb7cba42cb4c7589f77fb67dd95eb6293f62b3179c7b0 WHIRLPOOL cb1175430e97ba56b5dff85447c7be8dde9e25e92f10d98f0a79f34c5fd55e83209d6ff4e82d646f644f5ad5ef1ecbeef7196d3f89a6e1dc001d04b284cb38f6
diff --git a/games-util/nml/files/nml-0.4.4-pillow3.patch b/games-util/nml/files/nml-0.4.4-pillow3.patch
new file mode 100644
index 000000000000..e55d989fbc1b
--- /dev/null
+++ b/games-util/nml/files/nml-0.4.4-pillow3.patch
@@ -0,0 +1,11 @@
+--- nml-0.4.4.orig/nml/lz77.py
++++ nml-0.4.4/nml/lz77.py
+@@ -25,7 +25,7 @@
+ @return: Compressed data.
+ @rtype: C{bytearray}
+ """
+- stream = data.tostring()
++ stream = data.tobytes()
+ position = 0
+ output = array.array('B')
+ literal_bytes = array.array('B')
diff --git a/games-util/nml/nml-0.4.4.ebuild b/games-util/nml/nml-0.4.4.ebuild
new file mode 100644
index 000000000000..56979b798abc
--- /dev/null
+++ b/games-util/nml/nml-0.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Compiler of NML files into grf/nfo files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/nml"
+SRC_URI="http://bundles.openttdcoop.org/nml/releases/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="dev-python/pillow[zlib,${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( docs/{changelog,readme}.txt )
+PATCHES=( "${FILESDIR}"/${P}-pillow3.patch )
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/nmlc.1
+}