summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild
new file mode 100644
index 000000000000..307606f9a8d1
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kidletime:5
+ kde-frameworks/solid:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+ sys-power/upower
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}