summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-powermanagement/Manifest1
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-powermanagement/Manifest b/lxqt-base/lxqt-powermanagement/Manifest
index 7cbbf681e720..57850456cba6 100644
--- a/lxqt-base/lxqt-powermanagement/Manifest
+++ b/lxqt-base/lxqt-powermanagement/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-powermanagement-0.17.0.tar.xz 76080 BLAKE2B afd12f55d5274263707044c77f3c556dfbb4e2adebda600650e32130ea88a08b0b009c14c31217f85010182edae17cb0d58cd9bb83ba47a1d437e661ee7af6ea SHA512 24bd9a136dddd35b0fdedd5051764109965f3cd32c74acd78cbca1e5fcfc91cddf9a756665c6e700bf882ca0307bfcbc855bde5fbdb2509390e16366e7ee9548
DIST lxqt-powermanagement-0.17.1.tar.xz 76356 BLAKE2B bf1f6b599ed9a98faad550bdfcd1635114c42767a50578974d6b902d514ca0d2213b5f99e937a52d6c7ed4e1812db2e2c523b0ed8b0fcbb79cc52e7e6114ad33 SHA512 a08784fedc360610011b97ba1466480172fc1b4eb81ae3e6d65052affcd0ba3c122d476f37d55692d91ac4def30663fb09242fdbca8c0bb9fed0f60bed7dc579
+DIST lxqt-powermanagement-1.0.0.tar.xz 84900 BLAKE2B 74b2e66689ab205f6491762a8ecc491d2dbd1dd52feefa14a82b27f9f9c112563216eee8eb8e828939c35c54eec0ecf8099868cd932bb5318089f8129ca978a8 SHA512 004f10376c638c1566d28cd2caf8d68ddc91c3c882a4590296a649074b8181b5aba4e78d766e561e4868d17b08b78082ec45b44d26d4cae4b01a5f1cc652acc3
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild
new file mode 100644
index 000000000000..307606f9a8d1
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kidletime:5
+ kde-frameworks/solid:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+ sys-power/upower
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}