summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lastfmlib/lastfmlib-0.4.0.ebuild')
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
new file mode 100644
index 000000000000..e910f8670af6
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="http://code.google.com/p/lastfmlib/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog
+ find "${D}"/usr -name '*.la' -delete
+}