summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lastfmlib')
-rw-r--r--media-libs/lastfmlib/Manifest1
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0.ebuild33
-rw-r--r--media-libs/lastfmlib/metadata.xml16
3 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/Manifest b/media-libs/lastfmlib/Manifest
new file mode 100644
index 000000000000..367113770288
--- /dev/null
+++ b/media-libs/lastfmlib/Manifest
@@ -0,0 +1 @@
+DIST lastfmlib-0.4.0.tar.gz 333224 SHA256 28ecaffe2efecd5ac6ac00ba8e0a07b08e7fb35b45dfe384d88392ad6428309a
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
new file mode 100644
index 000000000000..e910f8670af6
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="http://code.google.com/p/lastfmlib/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog
+ find "${D}"/usr -name '*.la' -delete
+}
diff --git a/media-libs/lastfmlib/metadata.xml b/media-libs/lastfmlib/metadata.xml
new file mode 100644
index 000000000000..17f241ddb540
--- /dev/null
+++ b/media-libs/lastfmlib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>dirk.vdb@gmail.com</email>
+ <name>Dirk Vanden Boer</name>
+ <description>Proxy maintainer and upstream developer. Please CC him on bugs</description>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">lastfmlib</remote-id>
+ </upstream>
+</pkgmetadata>