summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arp-scan')
-rw-r--r--net-analyzer/arp-scan/Manifest1
-rw-r--r--net-analyzer/arp-scan/arp-scan-1.9.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/arp-scan/Manifest b/net-analyzer/arp-scan/Manifest
index 0baf0c1bce2b..0764da9f2f7f 100644
--- a/net-analyzer/arp-scan/Manifest
+++ b/net-analyzer/arp-scan/Manifest
@@ -1,2 +1,3 @@
DIST arp-scan-1.9.5.tar.gz 414114 BLAKE2B 8a38f74bc2660a43905a6db1411dbea4a29b030bc66e22cd569a7f3001a4a32553a9c09ace4b56db6b91d5a2bc2854b40b8af87034fed86e79f2d602893e71ae SHA512 a10c510dc668b103fc508619d04e5870fdf6f576b79222904cfe988b4e9255604ce1a724100318a662d5f77d33270bc733f0e3091fb9da034a54b9ab402cbcab
+DIST arp-scan-1.9.6.tar.gz 462479 BLAKE2B 21383167d83ba1cd9792f0a8d569c51ff196186fb59a2161c00d6963bcedecb706a419b08aeef2956bad72563f56a9a58b4231715b472a8ab083229b333d2e8f SHA512 c2d56ab8c6e1a046919892f6c2750593d6fbb3a539c3e1736184bd37ff7ae6033f84b62a3d2b4f56c0f2cdc1752002cb010ce77f701ee2f87b6f14b2e1753fe6
DIST arp-scan-1.9.tar.gz 488442 BLAKE2B f4170736c07ff69e044ca0c17150fafb5aee9de67463ce828a856d21e264c43e9354ba1663f630fa6c40628b97e97884588ca6c4b0f372263af087a78c45730b SHA512 5061ac82d1acad3dd5dab998e4e2d2d9d2dbf436a2839ee1f68dd2997278df7e77f5dda7e54bdb13c9200d7a714b8d82737c041cec8438571d1d14c9d7f936ac
diff --git a/net-analyzer/arp-scan/arp-scan-1.9.6.ebuild b/net-analyzer/arp-scan/arp-scan-1.9.6.ebuild
new file mode 100644
index 000000000000..b98d876c237a
--- /dev/null
+++ b/net-analyzer/arp-scan/arp-scan-1.9.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="ARP scanning and fingerprinting tool"
+HOMEPAGE="https://github.com/royhills/arp-scan"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}