summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bmon/bmon-9999.ebuild')
-rw-r--r--net-analyzer/bmon/bmon-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/bmon/bmon-9999.ebuild b/net-analyzer/bmon/bmon-9999.ebuild
new file mode 100644
index 000000000000..8fb8ce7ac06f
--- /dev/null
+++ b/net-analyzer/bmon/bmon-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools git-r3 linux-info toolchain-funcs
+
+DESCRIPTION="Interface bandwidth monitor"
+HOMEPAGE="https://github.com/tgraf/bmon/"
+EGIT_REPO_URI="https://github.com/tgraf/bmon/"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.3-r2:0=
+ dev-libs/confuse:=
+ dev-libs/libnl:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( NEWS README.md )
+
+CONFIG_CHECK="~NET_SCHED"
+ERROR_NET_SCHED="
+ CONFIG_NET_SCHED is not set when it should be.
+ Run ${PN} -i proc to use the deprecated proc interface instead.
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6-docdir-examples.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}