summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/bmon')
-rw-r--r--net-analyzer/bmon/bmon-4.0-r1.ebuild43
-rw-r--r--net-analyzer/bmon/bmon-4.0.ebuild4
-rw-r--r--net-analyzer/bmon/bmon-9999.ebuild (renamed from net-analyzer/bmon/bmon-999.ebuild)8
3 files changed, 49 insertions, 6 deletions
diff --git a/net-analyzer/bmon/bmon-4.0-r1.ebuild b/net-analyzer/bmon/bmon-4.0-r1.ebuild
new file mode 100644
index 000000000000..ce8d5207b86a
--- /dev/null
+++ b/net-analyzer/bmon/bmon-4.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info toolchain-funcs
+
+DESCRIPTION="Interface bandwidth monitor"
+HOMEPAGE="https://github.com/tgraf/bmon/"
+SRC_URI="https://codeload.github.com/tgraf/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ppc64 ~riscv ~sparc x86"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.3-r2:0=
+ dev-libs/confuse:=
+ dev-libs/libnl:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog NEWS README.md )
+
+CONFIG_CHECK="~NET_SCHED"
+ERROR_NET_SCHED="
+ CONFIG_NET_SCHED is not set when it should be.
+ Run ${PN} -i proc to use the deprecated proc interface instead.
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.6-docdir-examples.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
diff --git a/net-analyzer/bmon/bmon-4.0.ebuild b/net-analyzer/bmon/bmon-4.0.ebuild
index aa90421f0516..d8f7ff125c40 100644
--- a/net-analyzer/bmon/bmon-4.0.ebuild
+++ b/net-analyzer/bmon/bmon-4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
inherit autotools linux-info toolchain-funcs
DESCRIPTION="Interface bandwidth monitor"
-HOMEPAGE="http://www.infradead.org/~tgr/bmon/ https://github.com/tgraf/bmon/"
+HOMEPAGE="https://github.com/tgraf/bmon/"
SRC_URI="https://codeload.github.com/tgraf/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
LICENSE="BSD-2 MIT"
diff --git a/net-analyzer/bmon/bmon-999.ebuild b/net-analyzer/bmon/bmon-9999.ebuild
index c7b2e2c82e08..8fb8ce7ac06f 100644
--- a/net-analyzer/bmon/bmon-999.ebuild
+++ b/net-analyzer/bmon/bmon-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3 linux-info toolchain-funcs
DESCRIPTION="Interface bandwidth monitor"
-HOMEPAGE="http://www.infradead.org/~tgr/bmon/ https://github.com/tgraf/bmon/"
+HOMEPAGE="https://github.com/tgraf/bmon/"
EGIT_REPO_URI="https://github.com/tgraf/bmon/"
LICENSE="BSD-2 MIT"
@@ -20,7 +20,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-DOCS=( ChangeLog )
+DOCS=( NEWS README.md )
CONFIG_CHECK="~NET_SCHED"
ERROR_NET_SCHED="