summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/openvas-cli')
-rw-r--r--net-analyzer/openvas-cli/Manifest3
-rw-r--r--net-analyzer/openvas-cli/metadata.xml10
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.3.1.ebuild31
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4.0.ebuild33
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild33
5 files changed, 110 insertions, 0 deletions
diff --git a/net-analyzer/openvas-cli/Manifest b/net-analyzer/openvas-cli/Manifest
new file mode 100644
index 000000000000..3e310b25c3fe
--- /dev/null
+++ b/net-analyzer/openvas-cli/Manifest
@@ -0,0 +1,3 @@
+DIST openvas-cli-1.3.1.tar.gz 78956 SHA256 627711355541a5269a0fd827ff53189fbb5e6b33b45a27d2bb4bb4dcb24b70ef SHA512 46f049f7038b10e694534d64d0a1d793691d5416563586a830f98592a24a261e492ef47bbdbf09e2b97d3d9e23085e53171ed57590a729377740fca4f4eef0f2 WHIRLPOOL f540c3d9aa42468aa54b329bb39701b2d8dc2ca26f43453d3f27a93565211e4f45ea0584f899f2b93eb03ccf796d78a52af8a5bad556dbf757d7aeef7d9a19dc
+DIST openvas-cli-1.4.0.tar.gz 80886 SHA256 cc9ed4fffd3857183602c30a54254f1f4d0f94fc2a5fded57827e9b079266732 SHA512 65627f816bb787ce008ed8d109c9c59f6b14df9b47f6d7db823f48eb400b34b0c82638fd39ab953b26c0d96ccc45b349f62e79dfa42c91d64af9be84f32e3cd6 WHIRLPOOL 23d5d27e0f05f2920ae0be4feceb70b4ba980929fb76dfa3036e15d9b5dba2f71d32e8b27ba179b1d2c8c9bfc67c4c2c1f9bc20b3de16b686058c596d6d393c0
+DIST openvas-cli-1.4.2.tar.gz 82415 SHA256 ac06aac59af3a7d2bbccc17bf64915d0651b47b51a4b9c23efda5b0e76c8aff9 SHA512 a19ddab5907bfdaaa4080107225bd3fdf1d9ee0f2c34da7b9b43383904d0249f6992c6f80f5ac902c1ec34586b5a7a9f956b66c18db39d15484e848ba559193e WHIRLPOOL 37ab51e606d6faa6a1eb4430517b0910636af818c4e727502978b3dfe87c1e32659e73303a1171cc9652e94b6f8e566bd515aed0ff71659a1792f37d50b250b9
diff --git a/net-analyzer/openvas-cli/metadata.xml b/net-analyzer/openvas-cli/metadata.xml
new file mode 100644
index 000000000000..10fd5970fc9b
--- /dev/null
+++ b/net-analyzer/openvas-cli/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.3.1.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.3.1.ebuild
new file mode 100644
index 000000000000..b6335efb2963
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=1803
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-7.0.7
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4.0.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4.0.ebuild
new file mode 100644
index 000000000000..6b6eb04efc34
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=1987
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0.1
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
new file mode 100644
index 000000000000..0ab754a790be
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=2141
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0.4
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}