summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/tox')
-rw-r--r--net-libs/tox/tox-0.2.10.ebuild8
-rw-r--r--net-libs/tox/tox-0.2.9-r1.ebuild8
-rw-r--r--net-libs/tox/tox-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/net-libs/tox/tox-0.2.10.ebuild b/net-libs/tox/tox-0.2.10.ebuild
index 11d676ea6137..d8e4d1d2a74b 100644
--- a/net-libs/tox/tox-0.2.10.ebuild
+++ b/net-libs/tox/tox-0.2.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils systemd
+inherit cmake systemd
MY_P="c-toxcore-${PV}"
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
@@ -38,7 +38,7 @@ RDEPEND="
S="${WORKDIR}/${MY_P}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
#remove faulty tests
for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
@@ -81,11 +81,11 @@ src_configure() {
einfo "Logging disabled"
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use daemon; then
newinitd "${FILESDIR}"/initd tox-dht-daemon
diff --git a/net-libs/tox/tox-0.2.9-r1.ebuild b/net-libs/tox/tox-0.2.9-r1.ebuild
index 5307394b1288..a6e9875d9fcb 100644
--- a/net-libs/tox/tox-0.2.9-r1.ebuild
+++ b/net-libs/tox/tox-0.2.9-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils systemd
+inherit cmake systemd
MY_P="c-toxcore-${PV}"
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
@@ -31,7 +31,7 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
#remove faulty tests
for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
@@ -74,11 +74,11 @@ src_configure() {
einfo "Logging disabled"
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use daemon; then
newinitd "${FILESDIR}"/initd tox-dht-daemon
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-9999.ebuild
index 02c534562822..151001dd8ee2 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils git-r3 systemd
+inherit cmake git-r3 systemd
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
HOMEPAGE="https://tox.chat"
@@ -33,7 +33,7 @@ DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
#remove faulty tests
for testname in bootstrap lan_discovery save_compatibility tcp_relay tox_many_tcp; do
sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
@@ -74,11 +74,11 @@ src_configure() {
mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
einfo "Logging Disabled"
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use daemon; then
newinitd "${FILESDIR}"/initd tox-dht-daemon