summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/eugene/files')
-rw-r--r--sci-biology/eugene/files/eugene-3.6-overflow.patch13
-rw-r--r--sci-biology/eugene/files/eugene-3.6-plugins.patch43
-rw-r--r--sci-biology/eugene/files/eugene-4.1-format-security.patch16
3 files changed, 72 insertions, 0 deletions
diff --git a/sci-biology/eugene/files/eugene-3.6-overflow.patch b/sci-biology/eugene/files/eugene-3.6-overflow.patch
new file mode 100644
index 000000000000..7222530ad771
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=336607
+
+--- eugene-3.6/src/Sensor.cc
++++ eugene-3.6/src/Sensor.cc
+@@ -224,7 +224,7 @@
+ //--------------------------
+ void Signals :: PrintS ()
+ {
+- char t[7];
++ char t[10];
+ char s = '+';
+
+ switch (type) {
diff --git a/sci-biology/eugene/files/eugene-3.6-plugins.patch b/sci-biology/eugene/files/eugene-3.6-plugins.patch
new file mode 100644
index 000000000000..1e910a13d5b1
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-plugins.patch
@@ -0,0 +1,43 @@
+http://bugs.gentoo.org/show_bug.cgi?id=297536
+
+--- eugene-3.6/src/Makefile.am
++++ eugene-3.6/src/Makefile.am
+@@ -20,7 +20,7 @@
+
+ SUBDIRS = Parametrization GDIF . SensorPlugins
+
+-AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\"
++AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\" -DLIB_DIR=\"${libdir}\"
+ AM_CFLAGS =
+
+ bin_PROGRAMS = eugene
+--- eugene-3.6/src/MSensor.cc
++++ eugene-3.6/src/MSensor.cc
+@@ -97,7 +97,7 @@
+ std::string use_name;
+
+ if (!IsInitialized) {
+- PluginsDir = (std::string)PAR.getC("eugene_dir")+"/"+PLUGINS_DIR+"/";
++ PluginsDir = (std::string)LIB_DIR+"/eugene/"+PLUGINS_DIR+"/";
+
+ // On récupère les couples nom de sensor/priorité du .par
+ PAR.ResetIter();
+--- eugene-3.6/Makefile.am
++++ eugene-3.6/Makefile.am
+@@ -125,7 +125,7 @@
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
+- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
+@@ -144,6 +144,6 @@
+ $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
+- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
+ $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get
diff --git a/sci-biology/eugene/files/eugene-4.1-format-security.patch b/sci-biology/eugene/files/eugene-4.1-format-security.patch
new file mode 100644
index 000000000000..e6e4a6cc8bd7
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-4.1-format-security.patch
@@ -0,0 +1,16 @@
+ src/Hits.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Hits.cc b/src/Hits.cc
+index edfe178..b228be6 100755
+--- a/src/Hits.cc
++++ b/src/Hits.cc
+@@ -166,7 +166,7 @@ Hits* Hits::ReadFromFile(FILE* HitFile, int *NumHits, int level, int margin, int
+ while ((read=fscanf(HitFile,"%d %d %d %lf %d %s %d %d %as\n", &deb, &fin,
+ &poids, &evalue, &phase, HitId, &HSPDeb, &HSPFin,HSP)) >= 8)
+ {
+- if (HSP) fprintf(stderr,HSP);
++ if (HSP) fprintf(stderr, "%s", HSP);
+ if (phase < 0 && deb > fin)
+ {
+ int tmp = deb;