summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/maqview')
-rw-r--r--sci-biology/maqview/Manifest1
-rw-r--r--sci-biology/maqview/files/0.2.5-ldflags.patch46
-rw-r--r--sci-biology/maqview/files/0.2.5-zlib.patch33
-rw-r--r--sci-biology/maqview/files/maqview-0.2.5-gcc4.7.patch16
-rw-r--r--sci-biology/maqview/maqview-0.2.5-r2.ebuild32
-rw-r--r--sci-biology/maqview/metadata.xml8
6 files changed, 136 insertions, 0 deletions
diff --git a/sci-biology/maqview/Manifest b/sci-biology/maqview/Manifest
new file mode 100644
index 000000000000..f9ad87f8424e
--- /dev/null
+++ b/sci-biology/maqview/Manifest
@@ -0,0 +1 @@
+DIST maqview-0.2.5.tar.gz 383410 SHA256 156794f114a00bb455a47ccefa50782441dc1b9668b6e7439ce0674060c085cb SHA512 40bed0a1005ca96fdb12773cd9c22ddc926fe722c64652031609a17a50ff725a3dc117d51f4f27eda68b48861da78427469aaedff744f29921236b486396aed6 WHIRLPOOL 0ba5a15a1317b4bb78458b9e282348983be9e2c30980aef4e35a9f5dacfff57226eaa4403fb0b9d9d448ba033409d548db224ed544ad365226a8fb59be8b743e
diff --git a/sci-biology/maqview/files/0.2.5-ldflags.patch b/sci-biology/maqview/files/0.2.5-ldflags.patch
new file mode 100644
index 000000000000..92b9a3ed58ac
--- /dev/null
+++ b/sci-biology/maqview/files/0.2.5-ldflags.patch
@@ -0,0 +1,46 @@
+ configure.ac | 18 +++---------------
+ 1 files changed, 3 insertions(+), 15 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 90e612b..5a00d15 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9,17 +9,10 @@ AC_PROG_INSTALL
+ AC_STDC_HEADERS
+
+ is_static=0
+-case ${prefix} in
+- NONE);;
+- *) is_static=1
+- AC_MSG_WARN([Library libglut will be statically linked.])
+- LDFLAGS="-L${prefix}/lib"
+- CPPFLAGS="-I${prefix}/include";;
+-esac
+
+ # set CFLAGS and LDFLAGS
+
+-true_CFLAGS="-g -O2 -Wall -W -DMAQ_LONGREADS"
++true_CFLAGS="-DMAQ_LONGREADS"
+ case "${host_os}" in
+ darwin*)
+ GLLIBS="-framework OpenGL -framework GLUT"
+@@ -30,17 +23,12 @@ case "${host_os}" in
+ i?86) CPPFLAGS="$CPPFLAGS -D_FILE_OFFSET_BITS=64";;
+ esac
+ AC_CHECK_LIB([glut], [glutMouseWheelFunc], [CPPFLAGS="$CPPFLAGS -DHAVE_FREEGLUT"])
+- AC_ARG_ENABLE(static, [ --enable-static statically link GLUT (Linux Only)],
+- [is_static=1])
+- case $is_static in
+- 1) GLLIBS="-Wl,-Bstatic -lglut -Wl,-Bdynamic -lGL -lGLU -lm";;
+- 0) GLLIBS="-lGL -lglut -lm";;
+- esac
++ GLLIBS="-lGL -lglut -lm -lGLU"
+ AC_SUBST([GLLIBS]);;
+ # *) AC_MSG_ERROR([OS is not supported]);;
+ esac
+ AM_CONDITIONAL([HAVE_GL], [test "$isgl" = 1])
+-CFLAGS=$true_CFLAGS
++CFLAGS="${CFLAGS} $true_CFLAGS"
+
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/sci-biology/maqview/files/0.2.5-zlib.patch b/sci-biology/maqview/files/0.2.5-zlib.patch
new file mode 100644
index 000000000000..cd35273de66b
--- /dev/null
+++ b/sci-biology/maqview/files/0.2.5-zlib.patch
@@ -0,0 +1,33 @@
+ Makefile.am | 6 +++---
+ zrio.c | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index dad515a..9617eb7 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,8 @@
+ bin_PROGRAMS = zrio maqindex maqview maqindex_socks
+-zlib_src = adler32.c compress.c crc32.c deflate.c gzio.c inffast.c inflate.c \
+- infback.c inftrees.c trees.c uncompr.c zutil.c
+-generic_src = btree.c maqmap_index.c zrio.c stdhashc.h stdhashc.cc cns_cache.c const.c $(zlib_src)
++generic_src = btree.c maqmap_index.c zrio.c stdhashc.h stdhashc.cc cns_cache.c const.c
++LIBS = -lz
+ zrio_SOURCES = zrio_main.c $(generic_src)
++zrio_LDADD = -lz
+ maqindex_SOURCES = maqmap_index_main.c $(generic_src)
+ maqview_SOURCES = read_cache.c view_goto.c view_panel.c gl_gui.c MainFrame.c \
+ $(generic_src)
+diff --git a/zrio.c b/zrio.c
+index ffed00a..fe744df 100644
+--- a/zrio.c
++++ b/zrio.c
+@@ -506,7 +506,7 @@ int build_index(int in, int64_t span, struct access **built, void (*notify)(void
+ totin += strm.avail_in;
+ totout += strm.avail_out;
+ tmp = strm.avail_out;
+- ret = inflate_zr(&strm, Z_BLOCK); /* return at end of block */
++ ret = inflate(&strm, Z_BLOCK); /* return at end of block */
+ totin -= strm.avail_in;
+ totout -= strm.avail_out;
+ if(notify) notify(obj, window + WINSIZE - tmp, tmp - strm.avail_out, totout);
diff --git a/sci-biology/maqview/files/maqview-0.2.5-gcc4.7.patch b/sci-biology/maqview/files/maqview-0.2.5-gcc4.7.patch
new file mode 100644
index 000000000000..043208bb79b5
--- /dev/null
+++ b/sci-biology/maqview/files/maqview-0.2.5-gcc4.7.patch
@@ -0,0 +1,16 @@
+ stdhash.hh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/stdhash.hh b/stdhash.hh
+index eaf98af..f22c5a6 100644
+--- a/stdhash.hh
++++ b/stdhash.hh
+@@ -493,7 +493,7 @@ public:
+ inline bool insert(const keytype_t &key, const valtype_t &val) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ vals[i] = val;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
diff --git a/sci-biology/maqview/maqview-0.2.5-r2.ebuild b/sci-biology/maqview/maqview-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..e549497830bd
--- /dev/null
+++ b/sci-biology/maqview/maqview-0.2.5-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="GUI for sci-biology/maq, a short read mapping assembler"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="mirror://sourceforge/maq/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ media-libs/freeglut
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ sci-biology/maq"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-ldflags.patch
+ "${FILESDIR}"/${PV}-zlib.patch
+ "${FILESDIR}"/${P}-gcc4.7.patch
+ )
diff --git a/sci-biology/maqview/metadata.xml b/sci-biology/maqview/metadata.xml
new file mode 100644
index 000000000000..79ebcc09421b
--- /dev/null
+++ b/sci-biology/maqview/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="sourceforge">maq</remote-id>
+ </upstream>
+</pkgmetadata>