summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/chemex/chemex-2018.10.3.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sci-chemistry/chemex/chemex-2018.10.3.ebuild b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
index fc6cc2f0ca18..0c983b2eb24f 100644
--- a/sci-chemistry/chemex/chemex-2018.10.3.ebuild
+++ b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL="yes"
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -30,13 +30,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+distutils_enable_tests pytest
+
S="${WORKDIR}/ChemEx-${PV}"
src_prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
distutils-r1_src_prepare
}
-
-python_test() {
- py.test -v -v || die
-}