summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gmm/gmm-5.4.ebuild')
-rw-r--r--sci-mathematics/gmm/gmm-5.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/gmm-5.4.ebuild b/sci-mathematics/gmm/gmm-5.4.ebuild
new file mode 100644
index 000000000000..8d2188a730ae
--- /dev/null
+++ b/sci-mathematics/gmm/gmm-5.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
+SRC_URI="mirror://nongnu/getfem/stable/${P}.tar.gz"
+HOMEPAGE="http://getfem.org/gmm.html"
+
+LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}