summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmm/Manifest1
-rw-r--r--sci-mathematics/gmm/gmm-5.4.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/sci-mathematics/gmm/Manifest b/sci-mathematics/gmm/Manifest
index 084857e40367..5b275851d999 100644
--- a/sci-mathematics/gmm/Manifest
+++ b/sci-mathematics/gmm/Manifest
@@ -1,2 +1,3 @@
DIST gmm-5.1.tar.gz 537290 BLAKE2B bd8463e028554905d42190e9bbec7b8823271789331011ffc6da23f117cba9be4fec88b05343406d4bef557d7630b0a31c2a06df443708674341263f6ce7dfac SHA512 403074c2efedf2d9f63076a46faabb27c1bc19356284fac89aef58220ce0900d126b6f1a4f9bbef1641be1d609a8379729cad063695a570756ae0b2c470cedad
DIST gmm-5.3.tar.gz 540146 BLAKE2B 345c82303d82e1b87a6877e10ce6013edd81a62e365824bfe30747a1f577af65fc36337d848d4599a23bd9ea4942e3255a864bc2848ab1a4fc73a7de493320e4 SHA512 5f5bb25268d4357fc103f448c5bb3def49b16f1a03a54495b8c17c347ea3c6cb87435eb943c0fe3e9b46f75fa2ab7942ac63858c9eae01f865e1e4c6e4e7fa0a
+DIST gmm-5.4.tar.gz 547563 BLAKE2B 44d4809b84434e50e954d64ddd391ad39a2df8ff77b285b87615f1b7c0ce8dec6b4f002daf7fc6095c075ec60e32d7209ae3abba1899a42f8cc830b6fb33ff4a SHA512 a271755a69395f1fa3813be7fd65ecf123521ab5106acf3b87ecfc00a818ef476b669c65f6c29123f6351f9155ce3b5a02f17c8cff6d1821ad7c17ded0b854f5
diff --git a/sci-mathematics/gmm/gmm-5.4.ebuild b/sci-mathematics/gmm/gmm-5.4.ebuild
new file mode 100644
index 000000000000..8d2188a730ae
--- /dev/null
+++ b/sci-mathematics/gmm/gmm-5.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
+SRC_URI="mirror://nongnu/getfem/stable/${P}.tar.gz"
+HOMEPAGE="http://getfem.org/gmm.html"
+
+LICENSE="|| ( LGPL-3 LGPL-3-with-linking-exception )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # required for tests, #612294
+ append-cxxflags -std=c++14
+
+ default
+}