summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-readahead/systemd-readahead-216.ebuild')
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
index e256882d9165..a7580f0a561f 100644
--- a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -135,8 +135,16 @@ src_configure() {
}
src_compile() {
- echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
- emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > ./Makefile.extra
+ emake -f Makefile -f ./Makefile.extra BUILT_SOURCES
+
+ # Fix compilation, bug #607068
+ # From comments at https://aur.archlinux.org/packages/systemd-readahead
+ gperf < src/libsystemd/sd-bus/bus-error-mapping.gperf > src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/bus_error_mapping_lookup/s/size_t/unsigned int/" src/libsystemd/sd-bus/bus-error-mapping.c || die
+ sed -i -e "/lookup_errno/s/size_t/unsigned int/" src/shared/errno-from-name.h || die
+ sed -i -e "/lookup_af/s/size_t/unsigned int/" src/shared/af-from-name.h || die
+ sed -i -e "/lookup_arphrd/s/size_t/unsigned int/" src/shared/arphrd-from-name.h || die
emake systemd-readahead
emake units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer