summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/megamgr/megamgr-5.20-r2.ebuild')
-rw-r--r--sys-block/megamgr/megamgr-5.20-r2.ebuild23
1 files changed, 8 insertions, 15 deletions
diff --git a/sys-block/megamgr/megamgr-5.20-r2.ebuild b/sys-block/megamgr/megamgr-5.20-r2.ebuild
index d8758416c831..1ebc56400d12 100644
--- a/sys-block/megamgr/megamgr-5.20-r2.ebuild
+++ b/sys-block/megamgr/megamgr-5.20-r2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-
-inherit multilib
+EAPI=6
DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
HOMEPAGE="http://www.lsi.com"
@@ -15,29 +13,24 @@ SLOT="0"
# can remove the distfiles from their mirror anytime.
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror fetch"
DEPEND="app-arch/unzip"
RDEPEND=""
-RESTRICT="mirror fetch"
-
S="${WORKDIR}"
QA_PRESTRIPPED="/opt/bin/megamgr"
pkg_nofetch() {
einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
- einfo "Please visit $SRC_URI"
- einfo "And place $A in ${DISTDIR}"
-}
-
-pkg_setup() {
- use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+ einfo "Please visit ${SRC_URI}"
+ einfo "And place ${A} in ${DISTDIR}"
}
src_install() {
- newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
-
exeinto /opt/bin
- newexe megamgr.bin megamgr || die
+ newexe megamgr.bin megamgr
+
+ newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
}