summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/megamgr/Manifest2
-rw-r--r--sys-block/megamgr/megamgr-5.20-r2.ebuild23
2 files changed, 9 insertions, 16 deletions
diff --git a/sys-block/megamgr/Manifest b/sys-block/megamgr/Manifest
index b6ec0bccc994..3391acfcacde 100644
--- a/sys-block/megamgr/Manifest
+++ b/sys-block/megamgr/Manifest
@@ -1 +1 @@
-DIST ut_linux_mgr_5.20.zip 253549 SHA256 e7313ed8f59897f132ffed55ed606f19dc72a5d529e6b647cb157a39f0d79123 SHA512 3f942ab3d7a192bc1a945945d20545ffdbbbdd9c4af238701cf7357fe5b3f405c2e777da7c42908e1acb676499ee87aec261bcad729a4d787f8e098af132bda6 WHIRLPOOL 8efdfa1a152003ab0da0834f101c4da505974ada81eb0633e42d5065b96dcd48638da8145ac1e43573fe0cb25119bf3579a1d778deb18e1258cbca33e1c6cd28
+DIST ut_linux_mgr_5.20.zip 253549 BLAKE2B eb173d349e5399229f55ec073246993068caea01dcc707ec11d34a418cd42368eb80028e4363cad7e1bb707558e6eb8b629a2071387bff40471daa98d1d14c94 SHA512 3f942ab3d7a192bc1a945945d20545ffdbbbdd9c4af238701cf7357fe5b3f405c2e777da7c42908e1acb676499ee87aec261bcad729a4d787f8e098af132bda6
diff --git a/sys-block/megamgr/megamgr-5.20-r2.ebuild b/sys-block/megamgr/megamgr-5.20-r2.ebuild
index d8758416c831..1ebc56400d12 100644
--- a/sys-block/megamgr/megamgr-5.20-r2.ebuild
+++ b/sys-block/megamgr/megamgr-5.20-r2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
-
-inherit multilib
+EAPI=6
DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
HOMEPAGE="http://www.lsi.com"
@@ -15,29 +13,24 @@ SLOT="0"
# can remove the distfiles from their mirror anytime.
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror fetch"
DEPEND="app-arch/unzip"
RDEPEND=""
-RESTRICT="mirror fetch"
-
S="${WORKDIR}"
QA_PRESTRIPPED="/opt/bin/megamgr"
pkg_nofetch() {
einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
- einfo "Please visit $SRC_URI"
- einfo "And place $A in ${DISTDIR}"
-}
-
-pkg_setup() {
- use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+ einfo "Please visit ${SRC_URI}"
+ einfo "And place ${A} in ${DISTDIR}"
}
src_install() {
- newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
-
exeinto /opt/bin
- newexe megamgr.bin megamgr || die
+ newexe megamgr.bin megamgr
+
+ newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
}