summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/lld/lld-18.0.0_pre20231222.ebuild')
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231222.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(