summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/lld/lld-15.0.7.ebuild3
-rw-r--r--sys-devel/lld/lld-16.0.6.ebuild4
-rw-r--r--sys-devel/lld/lld-17.0.6.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0.9999.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231215.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231222.ebuild4
-rw-r--r--sys-devel/lld/lld-18.0.0_pre20231228.ebuild4
7 files changed, 20 insertions, 7 deletions
diff --git a/sys-devel/lld/lld-15.0.7.ebuild b/sys-devel/lld/lld-15.0.7.ebuild
index 9f1faebcbbbf..51a6a5bb778c 100644
--- a/sys-devel/lld/lld-15.0.7.ebuild
+++ b/sys-devel/lld/lld-15.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -69,6 +69,7 @@ src_configure() {
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-16.0.6.ebuild b/sys-devel/lld/lld-16.0.6.ebuild
index 274f0ff243dd..ab2cbc982c7f 100644
--- a/sys-devel/lld/lld-16.0.6.ebuild
+++ b/sys-devel/lld/lld-16.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -70,6 +70,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-17.0.6.ebuild b/sys-devel/lld/lld-17.0.6.ebuild
index 7289e547c49a..a6c8e30c0d8c 100644
--- a/sys-devel/lld/lld-17.0.6.ebuild
+++ b/sys-devel/lld/lld-17.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -68,6 +68,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0.9999.ebuild b/sys-devel/lld/lld-18.0.0.9999.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-18.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231215.ebuild b/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231215.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231222.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(
diff --git a/sys-devel/lld/lld-18.0.0_pre20231228.ebuild b/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
index c99759356a66..3dd9c8c26a2e 100644
--- a/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
+++ b/sys-devel/lld/lld-18.0.0_pre20231228.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,6 +67,8 @@ src_configure() {
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr/lib/llvm/${LLVM_MAJOR}"
-DBUILD_SHARED_LIBS=ON
-DLLVM_INCLUDE_TESTS=$(usex test)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
)
use test && mycmakeargs+=(