summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/lld/lld-19.0.0_pre20240224.ebuild')
-rw-r--r--sys-devel/lld/lld-19.0.0_pre20240224.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
+++ b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"