summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-17.0.6.ebuild3
-rw-r--r--sys-devel/lld/lld-18.1.0_rc3.ebuild3
-rw-r--r--sys-devel/lld/lld-18.1.0_rc4.ebuild3
-rw-r--r--sys-devel/lld/lld-19.0.0.9999.ebuild3
-rw-r--r--sys-devel/lld/lld-19.0.0_pre20240224.ebuild3
5 files changed, 15 insertions, 0 deletions
diff --git a/sys-devel/lld/lld-17.0.6.ebuild b/sys-devel/lld/lld-17.0.6.ebuild
index 628ca40e4df2..6b93f3ac17e8 100644
--- a/sys-devel/lld/lld-17.0.6.ebuild
+++ b/sys-devel/lld/lld-17.0.6.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
}
src_configure() {
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-18.1.0_rc3.ebuild b/sys-devel/lld/lld-18.1.0_rc3.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-18.1.0_rc3.ebuild
+++ b/sys-devel/lld/lld-18.1.0_rc3.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-18.1.0_rc4.ebuild b/sys-devel/lld/lld-18.1.0_rc4.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-18.1.0_rc4.ebuild
+++ b/sys-devel/lld/lld-18.1.0_rc4.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-19.0.0.9999.ebuild b/sys-devel/lld/lld-19.0.0.9999.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-19.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-19.0.0.9999.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
index db957ad1ab9a..5440a5c89919 100644
--- a/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
+++ b/sys-devel/lld/lld-19.0.0_pre20240224.ebuild
@@ -58,6 +58,9 @@ src_unpack() {
src_configure() {
llvm_prepend_path "${LLVM_MAJOR}"
+ # ODR violations (https://github.com/llvm/llvm-project/issues/83529, bug #922353)
+ filter-lto
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"