summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obtheme')
-rw-r--r--x11-misc/obtheme/Manifest1
-rw-r--r--x11-misc/obtheme/metadata.xml6
-rw-r--r--x11-misc/obtheme/obtheme-2013.2.20.2.ebuild31
3 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/obtheme/Manifest b/x11-misc/obtheme/Manifest
new file mode 100644
index 000000000000..c19ac1448ee8
--- /dev/null
+++ b/x11-misc/obtheme/Manifest
@@ -0,0 +1 @@
+DIST obtheme-2013.2.20.2.tar.xz 25080 SHA256 3e183092c9340347628412b6af36e54eda863deb8f4e8d26f1a78f2f512fe685 SHA512 5e7d1d187c0d5f3e6851b3a09be9aeed3b2708277940abd19efba4a501bf3ab20e0307f51e4b63e33ba07d301abf41607cec7074b3e478c9c5e6b065b3773f77 WHIRLPOOL 4d2d053199b6987747037fc06700ce1ec066cc52fc85e247eecb366f9bbfccdb6088aaed1304cbd41ec77a279dab5a97f633867e8661569aac15c8ebf46b0178
diff --git a/x11-misc/obtheme/metadata.xml b/x11-misc/obtheme/metadata.xml
new file mode 100644
index 000000000000..9360f354d02a
--- /dev/null
+++ b/x11-misc/obtheme/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
+
diff --git a/x11-misc/obtheme/obtheme-2013.2.20.2.ebuild b/x11-misc/obtheme/obtheme-2013.2.20.2.ebuild
new file mode 100644
index 000000000000..5a7bd4ed2601
--- /dev/null
+++ b/x11-misc/obtheme/obtheme-2013.2.20.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="A gui theme editor for openbox"
+HOMEPAGE="http://xyne.archlinux.ca/projects/obtheme/"
+SRC_URI="http://xyne.archlinux.ca/projects/obtheme/src/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/fuse-python
+ x11-libs/gtk+:2
+"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ domenu ${PN}.desktop
+ dodoc README CHANGELOG
+}