summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild')
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
new file mode 100644
index 000000000000..70a26acef4a9
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+HOMEPAGE="https://github.com/voyageur/wmsysmon"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+DOCS=( ../ChangeLog ../README )
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmsysmon
+ einstalldocs
+}