summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmsysmon')
-rw-r--r--x11-plugins/wmsysmon/Manifest3
-rw-r--r--x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch23
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild (renamed from x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild)8
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild32
4 files changed, 38 insertions, 28 deletions
diff --git a/x11-plugins/wmsysmon/Manifest b/x11-plugins/wmsysmon/Manifest
index 12e312cd5b7f..6385c75444c2 100644
--- a/x11-plugins/wmsysmon/Manifest
+++ b/x11-plugins/wmsysmon/Manifest
@@ -1 +1,2 @@
-DIST wmsysmon-0.7.8.tar.gz 23533 BLAKE2B 830edc78222e8997c6ee23bdd9fcb28729e9b80d92b07f70a53d841065b7377f5c450024c511b4faa92043bd45aa0cc92e89ff900d7d4a53d3c9f4b57b4e6e7e SHA512 b1afd176851e8f89896e39b55d24d6efeb97eb5fdbb9c181cb030320445f1d8b22d31073edc615e6b47b91fd133b381f00b612901c8b312e7da404a4746bb97c
+DIST wmsysmon-0.8.0.tar.gz 21262 BLAKE2B 50c7e3149fbad711f7505558549eadede78abf4f52d5c2c6eff0bd74bbb9838f85b78d73a7021a3baf9776cdccfb2b8e621de897fdafe5a7af71cd8518933852 SHA512 af9f939de5031387abf31d7ad9b4f767056a5f0d1494ee95476fb6c3bafab95ffe78148da74bf004b40a1e0d4ace9616c272bce0f4900491c8983c34531c29e7
+DIST wmsysmon-0.8.1.tar.gz 21276 BLAKE2B 17711e383f6285bccb16eeae83bfd302e73bed4b9744aa2ef78e228ff103f2342d024668cf285578cbebb3f9cbbd14ae3b5bab26b3454bb973449cc124068f0c SHA512 d6ce023683083de292284f6e155053a6da2dad87365d63c296b857507f803426fc68880c90489c3f5bd756bf66359b5d4624e928afec9cd1d0a3d5792a3a8f2b
diff --git a/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch b/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch
deleted file mode 100644
index e9477899b1b9..000000000000
--- a/x11-plugins/wmsysmon/files/wmsysmon-0.7.8-gcc-10.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur src.orig/wmgeneral.h src/wmgeneral.h
---- src.orig/wmgeneral.h 2017-12-06 15:00:16.000000000 +0100
-+++ src/wmgeneral.h 2020-03-01 16:03:18.293199660 +0100
-@@ -38,7 +38,7 @@
- /* Global variable */
- /*******************/
-
--Display *display;
-+extern Display *display;
-
- /***********************/
- /* Function Prototypes */
-diff -Naur src.orig/wmsysmon.c src/wmsysmon.c
---- src.orig/wmsysmon.c 2017-12-06 15:00:16.000000000 +0100
-+++ src/wmsysmon.c 2020-03-01 16:03:32.992203044 +0100
-@@ -138,6 +138,7 @@
- time_t curtime;
- time_t prevtime;
-
-+Display *display;
-
- kernel_versions Get_Kernel_version(void);
- void usage(void);
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
index 4a1faee41b23..70a26acef4a9 100644
--- a/x11-plugins/wmsysmon/wmsysmon-0.7.8.ebuild
+++ b/x11-plugins/wmsysmon/wmsysmon-0.8.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
@@ -13,12 +13,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND="x11-libs/libX11
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
DOCS=( ../ChangeLog ../README )
S=${WORKDIR}/${P}/src
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild
new file mode 100644
index 000000000000..6d98e0bd7d33
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.8.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+HOMEPAGE="https://github.com/voyageur/wmsysmon"
+SRC_URI="https://github.com/voyageur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+DOCS=( ../ChangeLog ../README )
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmsysmon
+ einstalldocs
+}