summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}