summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty-terminfo')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 2d5fb2a6e2ae..9c3a145fcdf7 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
DIST kitty-0.32.0.tar.xz 8122660 BLAKE2B 8f2fccb8f233612331b860e0b25aa5a028c2e4d39b5795132351c4a2dff51478b8e42fd3a15bec5f616b4cdb47ad0cc7f636d1961a7f9fad8ede91475e82c29e SHA512 d64f36c20d484724b0215a2ffc9044b83ddaa476926377e6c79226d7d6bd5deffda9964291a99c0df174640fb2fa7df0464435d2cef19304eab7b1d135cc1847
+DIST kitty-0.32.1.tar.xz 8115412 BLAKE2B 493b250c3b456e895646175602997d902f457f8935be2b2cc21e41f6efbc963865eff6157d31427a65e9d0976e87965a646ef77cfdee28d96aeb710e6a905c4c SHA512 4be50093b2da7a6536548f8bf36ea86ab47238a1f346e10d4384a90d2d0d0e02f8d98dc6a463ffa7c7a93268202b5a4109f28e2b7ece1d9593f590691e5e1af8
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.32.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}