summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild
new file mode 100644
index 000000000000..4ed05e3230f1
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+MY_PN="${PN/-icon-theme/}"
+
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="media-gfx/optipng
+ sys-apps/findutils"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/icons/
+ dodoc README.md
+ for shade in elementary-xfce*; do
+ for doc in {AUTHORS,CONTRIBUTORS,LICENSE}; do
+ if [[ -f ${shade}/${doc} ]]; then
+ newdoc ${shade}/${doc} ${shade}-${doc}
+ rm -f ${shade}/${doc} || die
+ elif [[ -L ${shade}/${doc} ]]; then
+ unlink ${shade}/${doc} || die
+ fi
+ done
+ doins -r ${shade}
+ done
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }