summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/elementary-xfce-icon-theme/Manifest1
-rw-r--r--x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/elementary-xfce-icon-theme/Manifest b/x11-themes/elementary-xfce-icon-theme/Manifest
index d99928e14153..562f03ea286a 100644
--- a/x11-themes/elementary-xfce-icon-theme/Manifest
+++ b/x11-themes/elementary-xfce-icon-theme/Manifest
@@ -1 +1,2 @@
DIST elementary-xfce-icon-theme-0.11.tar.gz 7945508 BLAKE2B 2a313e72bb71deed37a69bfb4186d5133c1d6dc721c7364a7ee63aef80181421cad6100ad12a6585daf6e8f0256579cde6aaf29540561816071721b454231560 SHA512 77695f25cd09afa595fdb49b40b5b605f791ad498cb795aa441c51fd89e2e99e4effd21ade9f62aceccfd4b682d1f95b9656dae97cff17e6c7a1ce159d3672b0
+DIST elementary-xfce-icon-theme-0.13.1.tar.gz 6270817 BLAKE2B c4fa8b6de5a839dfaa564f2b850598d6d071912fcd892348e5e0c77095c89c47091351097c7e3a50eb9cc2518f36d23c1216aea59b22d0ef321235edae0a1fbb SHA512 6a0de74110a7a9d0052e469c930b518a7e4582fd499cffe4322b22148bc0dcbe62bfaf1181aa0f6e3dd3fe5eab85dacfeabc9d280303fb2377581e6ac93832e2
diff --git a/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild
new file mode 100644
index 000000000000..4ed05e3230f1
--- /dev/null
+++ b/x11-themes/elementary-xfce-icon-theme/elementary-xfce-icon-theme-0.13.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+MY_PN="${PN/-icon-theme/}"
+
+DESCRIPTION="Elementary icons forked from upstream, extended and maintained for Xfce"
+HOMEPAGE="https://github.com/shimmerproject/elementary-xfce"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain GPL-1 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="media-gfx/optipng
+ sys-apps/findutils"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/icons/
+ dodoc README.md
+ for shade in elementary-xfce*; do
+ for doc in {AUTHORS,CONTRIBUTORS,LICENSE}; do
+ if [[ -f ${shade}/${doc} ]]; then
+ newdoc ${shade}/${doc} ${shade}-${doc}
+ rm -f ${shade}/${doc} || die
+ elif [[ -L ${shade}/${doc} ]]; then
+ unlink ${shade}/${doc} || die
+ fi
+ done
+ doins -r ${shade}
+ done
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }