summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-util/debugedit: Remove obsolete updater scriptMichał Górny5 hours1-84/+0
| | | | | | We are now using upstream tarballs, so the script is no longer relevant. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/debugedit: Bump to 4.14.2Michał Górny5 hours2-0/+90
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/debugedit: Take maintenance overMichał Górny5 hours1-4/+8
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/lldb: Bump to 7.0.0 finalMichał Górny7 hours2-5/+5
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* dev-util/cppcheck-1.84-r1: added ~ppc64, bug 664470Matt Turner28 hours1-1/+1
|
* dev-util/cppcheck: Add upstream patch to fix testMatt Turner28 hours2-0/+198
| | | | | | | On some platforms 'char' is unsigned by default, causing the test to fail. See https://trofi.github.io/posts/203-signed-char-or-unsigned-char.html
* dev-util/spirv-tools: Require newer spirv-headersNick Sarnie29 hours2-2/+2
| | | | | Fixes: https://bugs.gentoo.org/666488 Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/ninja: bump to EAPI 7Mike Gilbert31 hours1-8/+8
| | | | | Signed-off-by: Mike Gilbert <floppym@gentoo.org> Package-Manager: Portage-2.3.49_p2, Repoman-2.3.10_p48
* dev-util/boost-build: Drop stray 1.62.0Andreas Sturmlechner32 hours2-141/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/boost-build: stable 1.65.0 for sparc, bug #644808Rolf Eike Beer32 hours1-1/+1
| | | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 RepoMan-Options: --include-arches="sparc" Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-util/meson: remove several older versionsWilliam Hubbs35 hours4-121/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/debhelper: Old.Jeroen Roovers37 hours3-148/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/debhelper: Version 11.4.Jeroen Roovers37 hours2-0/+74
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/vulkan-headers: Drop oldNick Sarnie2 days1-25/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/vulkan-tools: Drop oldNick Sarnie2 days1-89/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/vulkan-tools: Bump to 1.1.82.0Nick Sarnie2 days3-18/+119
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/vulkan-headers: Bump to 1.1.82.0Nick Sarnie2 days2-0/+26
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/spirv-tools: Drop oldNick Sarnie2 days2-40/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/spirv-tools: Bump to v2018.5Nick Sarnie2 days2-0/+38
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/spirv-headers: Version bumpNick Sarnie2 days2-0/+18
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/glslang: Bump to 7.9.2888Nick Sarnie2 days2-0/+17
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/mingw64-runtime: cleanup oldAlon Bar-Lev2 days19-1660/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/mingw64-runtime: verison bumpAlon Bar-Lev2 days2-0/+107
| | | | | | | for some reason console application is not working on my windows machine, more testing need to be done, removed keywords. Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/mdds: Drop 1.4.1 (never got keyworded)Andreas Sturmlechner3 days2-51/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/mdds: 1.4.2 version bump, still no keywordsAndreas Sturmlechner3 days2-0/+51
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/boost-build: add patch to unbreak compiler options on sparcRolf Eike Beer3 days6-0/+52
| | | | | | | | | | | | | | | Boost tries to autodetect the processor architecture and overrides any flags set with CXXFLAGS with the -mcpu value it thinks it is appropiate. Sadly the most recent architecture it knows of is ultrasparc3. For every newer cpu type it falls back to it's default, which is v7 (which would be the compiler default anyway). This avoids any advanced cpu instructions, e.g. those that support atomic operations on thing larger than a byte. Remove the whole outdated cruft and just use whatever the user passed in. Closes: https://bugs.gentoo.org/646234 Closes: https://github.com/gentoo/gentoo/pull/9802 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/meson: sh/m68k stable wrt bug #656920Mikle Kolyada4 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/pycharm-community: fix keywords regressionMikle Kolyada4 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/pycharm-professional: fix keywords regressionMikle Kolyada4 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/dbus-test-runner: Drop 12.10.1Andreas Sturmlechner4 days2-36/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/gperf: mark stable wrt bug #656752Mikle Kolyada4 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/bazel: drop oldJason Zaman4 days2-142/+0
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/bazel: bump 0.17.1Jason Zaman4 days2-0/+124
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/debootstrap: Old.Jeroen Roovers5 days2-49/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/debootstrap: Version 1.0.109.Jeroen Roovers5 days2-0/+49
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/re2c-1.0.3-r0: alpha stableTobias Klausmann6 days1-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/664924
* dev-util/dbus-test-runner-15.04.0_p100-r0: alpha stableTobias Klausmann6 days1-1/+1
| | | | Gentoo-Bug: http://bugs.gentoo.org/663972
* dev-util/catalyst: Depend on a released version of dev-python/pydecompMatt Turner6 days1-1/+1
| | | | dev-python/pydecomp-0.3 is the latest commit in git.
* dev-util/jenkins-bin: add 2.138.1Hans de Graaff6 days2-0/+47
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/gn: amd64 stable wrt bug #665340Mikle Kolyada7 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/mdds: 1.4.1 version bump without keywordsAndreas Sturmlechner7 days2-0/+51
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/cargo: add sub slot operator on net-libs/http-parser atomThomas Deutschmann7 days4-4/+4
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/gnome-builder: x86 keyworded (bug #664922)Thomas Deutschmann8 days1-1/+1
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/checkbashisms: Bump to version 2.18.4Lars Wendler9 days2-0/+41
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/cargo: tweak the build command and die earlyDirkjan Ochtman9 days1-2/+2
|
* dev-util/lldb: Bump to 7.0.0rc3Michał Górny9 days2-2/+2
|
* dev-util/cmake: Removed old.Lars Wendler10 days2-221/+0
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/cmake: Bump to version 3.12.2Lars Wendler10 days2-0/+224
| | | | Package-Manager: Portage-2.3.49, Repoman-2.3.10
* dev-util/cargo: depend on recent rustDirkjan Ochtman10 days1-1/+1
| | | | | | | This hopefully prevents compilation failures to a too old compiler. Closes: https://bugs.gentoo.org/664484 Package-Manager: Portage-2.3.40, Repoman-2.3.9
* dev-util/cargo: amd64 stable wrt bug #662904Mikle Kolyada11 days1-1/+1
| | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9