summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* games-engines/openmw: version 0.47Alexey Sokolov12 days3-17/+154
| | | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/22579 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-engines/openmw: flag-o-matic-- for UnusedInheritsIonen Wolkens2021-09-121-1/+1
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* games-engines/openmw: fix build with boost-1.77.0Ionen Wolkens2021-08-172-0/+11
| | | | | Closes: https://bugs.gentoo.org/808763 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-engines/openmw: remove recastnavigation hack from 9999Alexey Sokolov2021-08-161-2/+0
| | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: use newer OSG for 9999Alexey Sokolov2021-07-301-3/+3
| | | | | | | Bug: https://bugs.gentoo.org/797403 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-engines/openmw: add lua supportAlexey Sokolov2021-07-141-3/+22
| | | | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/21606 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-engines/openmw: Depend on dev-libs/boost:=[threads(+)]David Seifert2021-06-182-4/+4
| | | | | Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
* games-engines/openmw: 0.46 requires OSG 3.4Alexey Sokolov2021-06-051-1/+1
| | | | | | | | | | | | This is in preparation for future 0.47. The discussion with upstream revealed that 0.46 works best with the forked OSG 3.4, 3.6 is not recommended for it. But 0.47 needs 3.6, also with a preference to use the forked OSG. Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/21136 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* games-engines/openmw: remove openmw-0.47.0-bullet-debian.patchAlexey Sokolov2021-05-062-16/+0
| | | | | | | | https://gitlab.com/OpenMW/openmw/-/commit/e3a6cb1695336c834c9664eabc40028f01e3b99f includes it Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: fix build with gcc 11Alexey Sokolov2021-05-062-0/+37
| | | | | Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: require boost[zlib]Alexey Sokolov2021-05-062-3/+3
| | | | | | Closes: https://bugs.gentoo.org/788253 Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* */*: Add proxied="yes" for non-@gentoo.org peopleMichał Górny2021-03-161-1/+1
| | | | | | | | | | | | Done via: find -name metadata.xml -exec xml ed -P -L \ -a '/pkgmetadata/maintainer[substring(email, string-length(email) - string-length("@gentoo.org") + 1) != "@gentoo.org"]' \ -t attr -n proxied -v yes {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Add 'proxied="proxy"' for proxy-maint projectMichał Górny2021-03-161-1/+1
| | | | | | | | | | Done via: find -name metadata.xml -exec xml ed -P -L \ -a '//maintainer[email="proxy-maint@gentoo.org"]' \ -t attr -n proxied -v proxy {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-engines/openmw: fix build of 9999Alexey Sokolov2021-03-082-6/+19
| | | | | | | Closes: https://bugs.gentoo.org/773211 Signed-off-by: Alexey Sokolov <sokolov@google.com> Thanks-to: Benjamin Winger <bmw@disroot.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: restrict double-precisionness of bulletAlexey Sokolov2020-10-132-2/+3
| | | | | | | | | | | | | | | For 0.46.0, require no double precision. For 9999, require double precision instead. Upstream references: https://github.com/OpenMW/openmw/pull/2049 https://github.com/OpenMW/openmw/pull/2848 Closes: https://bugs.gentoo.org/747898 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17896 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: update the 9999-only patchAlexey Sokolov2020-10-131-8/+8
| | | | | | | | To fix build Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: drop old 0.45.0Alexey Sokolov2020-08-174-204/+0
| | | | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17064 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-engines/openmw: update the patch for 9999Alexey Sokolov2020-08-172-1/+17
| | | | | | Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-engines/openmw: version bump - 0.46.0Alexey Sokolov2020-07-0810-11/+933
| | | | | | | | | | | | Add option to use forked OSG Fix build on ~arch, fix tests on i686, fix installation on Prefix Closes: https://bugs.gentoo.org/673864 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/16000 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* games-engines/openmw: add live ebuildAlexey Sokolov2020-05-272-0/+150
| | | | | | | | And add me (with p-m) to maintainers Signed-off-by: Alexey Sokolov <sokolov@google.com> Closes: https://github.com/gentoo/gentoo/pull/15400 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* games-engines/openmw: No sign of private Qt header use, drop slot opsAndreas Sturmlechner2020-03-141-5/+5
| | | | | Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* games-engines/openmw: Fix build w/ >=dev-games/openscenegraph-3.6.5Andreas Sturmlechner2020-03-143-0/+74
| | | | | | Bug: https://bugs.gentoo.org/709878 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* */*: Bump copyright on files touched this yearMichał Górny2020-02-111-1/+1
| | | | | | | Update the copyright notice on all files that were touched since January 1st but did not have the notice updated. Signed-off-by: Michał Górny <mgorny@gentoo.org>
* */*: Switch games proj to cmake.eclassAndreas Sturmlechner2020-01-041-6/+6
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* games-engines/openmw: Drop old 0.44.0James Le Cuirot2019-07-282-127/+0
| | | | | Package-Manager: Portage-2.3.69, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-engines/openmw: Bump to 0.45.0, EAPI 7, fix dependenciesJames Le Cuirot2019-07-282-0/+130
| | | | | Package-Manager: Portage-2.3.69, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
* games-engines/openmw: Add missing OSG slot op, drop pkg_preinstAndreas Sturmlechner2018-12-231-7/+8
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* games-engines/openmw: Drop 0.43.0-r2Andreas Sturmlechner2018-12-233-209/+0
| | | | | Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* games-engines/openmw: version bump to 0.44.0.ktrace2018-08-212-0/+126
| | | | | Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9540
* games-engines/openmw: Drop nonexistent dependencyAndreas Sturmlechner2018-07-151-7/+2
| | | | | Closes: https://bugs.gentoo.org/657728 Package-Manager: Portage-2.3.42, Repoman-2.3.9
* games-engines/openmw: Fix build with Qt 5.11_beta3Andreas Sturmlechner2018-04-172-0/+83
| | | | Package-Manager: Portage-2.3.30, Repoman-2.3.9
* games-engines/openmw: Drop 0.42.0, broken by OSG-3.5.1 removalAndreas Sturmlechner2018-03-182-134/+0
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/openmw: Ebuild compatibility w/ >=OSG-3.5.5Andreas Sturmlechner2018-02-071-2/+7
| | | | | | | Ultimately, the nature of OSG-Qt requirement needs to be checked if only RDEPEND or also DEPEND. Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/openmw: version bump to 0.4.3Victor2018-01-122-0/+126
| | | | | | | | | Bump version Closes: https://bugs.gentoo.org/643486 Closes: https://github.com/gentoo/gentoo/pull/6824 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6824
* games-engines/openmw: Remove oldDavid Seifert2017-12-212-135/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/*: Update Manifest hashesMichał Górny2017-12-101-2/+2
|
* games-engines/openmw: version bump to 0.42coyote2017-11-012-0/+134
| | | | Closes: https://github.com/gentoo/gentoo/pull/6018
* games-engines/openmw: Drop oldAndreas Sturmlechner2017-03-022-97/+0
| | | | | Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4099
* Drop $Id$ per council decision in bug #611234.Robin H. Johnson2017-02-282-2/+0
| | | | Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
* games-engines/openmw: s/default/cmake-utils_src_prepare/Andreas Sturmlechner2017-02-181-1/+1
| | | | Package-Manager: portage-2.3.3
* games-engines/openmw: Drop oldAndreas Sturmlechner2017-02-181-101/+0
| | | | Package-Manager: portage-2.3.3
* games-engines/openmw: 0.41.0 version bumpAndreas Sturmlechner2017-02-182-0/+136
| | | | | | | Gentoo-bug: 592864 Thanks-to: eroen <gentoo@eroen.eu> Package-Manager: portage-2.3.3
* games-engines/openmw: remove deprecated games eclassAustin English2016-11-111-0/+97
| | | | | | | | Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
* games-engines/openmw: clean oldMichael Sterrett2016-06-072-102/+0
| | | | Package-Manager: portage-2.2.28
* games-engines/openmw: version bump (bug #567742)Michael Sterrett2016-05-242-0/+102
| | | | Package-Manager: portage-2.2.28
* games-engines/openmw: Cleanup due to #408423Pacho Ramos2016-05-221-4/+0
| | | | Package-Manager: portage-2.3.0_rc1
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-2/+2
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+4
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-241-1/+0
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.