aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-17 19:21:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-02-17 19:21:22 +0100
commit10e29e31f623fd98220f9a0e86492ab8ba97b9f2 (patch)
tree34598c021d997d164912dd649090a74939592b65
parentdev-python/stdio-mgr: add py3.8 and 3.9 (diff)
downloadguru-10e29e31f623fd98220f9a0e86492ab8ba97b9f2.tar.gz
guru-10e29e31f623fd98220f9a0e86492ab8ba97b9f2.tar.bz2
guru-10e29e31f623fd98220f9a0e86492ab8ba97b9f2.zip
dev-python/sphobjinv: add py3.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.0.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/sphobjinv/sphobjinv-2.0.1.ebuild b/dev-python/sphobjinv/sphobjinv-2.0.1.ebuild
index 9550dad35..52f906ca8 100644
--- a/dev-python/sphobjinv/sphobjinv-2.0.1.ebuild
+++ b/dev-python/sphobjinv/sphobjinv-2.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -17,7 +17,7 @@ HOMEPAGE="
SRC_URI="https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 "
+KEYWORDS="~amd64 ~x86"
SLOT="0"
RDEPEND="
@@ -47,6 +47,9 @@ python_prepare_all() {
# not sure why this fails
rm tests/test_flake8_ext.py || die
+ # --strict option is deprecated in pytest>6
+ sed -i -e '/addopts/d' tox.ini || die
+
distutils-r1_python_prepare_all
}