aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 00:08:27 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 02:37:16 +0200
commit7406ddd6c411013f1c67c938fe265c162397c345 (patch)
tree56f6ba99cbc3ab63d67f97983ec0d34acd3f7ebf
parentdev-python/text-unidecode: new package (diff)
downloadguru-7406ddd6c411013f1c67c938fe265c162397c345.tar.gz
guru-7406ddd6c411013f1c67c938fe265c162397c345.tar.bz2
guru-7406ddd6c411013f1c67c938fe265c162397c345.zip
dev-python/aiohttp-cors: bump to python3.8
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild
new file mode 100644
index 0000000000..2c9822a195
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.7.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+# https://github.com/aio-libs/aiohttp-cors/pull/278
+PATCHES=(
+ "${FILESDIR}/${P}-tests.patch"
+ "${FILESDIR}/${P}-py3_7.patch"
+)
+
+src_prepare() {
+ sed -i -e '/^addopts=/d' setup.cfg || die
+ distutils-r1_src_prepare
+}