aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:36:20 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:36:20 +0200
commit9bb5a5bd7f3cd870b669e8336d8d7fd19369aebf (patch)
treed707282057a97e26bf37e928da81812f2ae915e7
parentdev-python/httpcore: new package (diff)
downloadguru-9bb5a5bd.tar.gz
guru-9bb5a5bd.tar.bz2
guru-9bb5a5bd.zip
dev-python/sanic: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/sanic/Manifest1
-rw-r--r--dev-python/sanic/metadata.xml15
-rw-r--r--dev-python/sanic/sanic-19.12.2.ebuild51
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/sanic/Manifest b/dev-python/sanic/Manifest
new file mode 100644
index 000000000..c4f1f4dd7
--- /dev/null
+++ b/dev-python/sanic/Manifest
@@ -0,0 +1 @@
+DIST sanic-19.12.2.tar.gz 195755 BLAKE2B 0d903b06403f28a901d21bfc685219064d0ec2b11576baf714aa3250cc3474928da03c34f0a5a25bf92191242b0a41f76d41aabe92a805bea1801e569c892e9a SHA512 93e416ceea5577db4c443dd6dd03cc5e990d4f987d49821b70d5602421d38401e155e2aad166c88ec57fc5361350c641f087b461a6d92acde34455db81429c5c
diff --git a/dev-python/sanic/metadata.xml b/dev-python/sanic/metadata.xml
new file mode 100644
index 000000000..2208048e8
--- /dev/null
+++ b/dev-python/sanic/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <longdescription lang="en">
+Sanic is a Python 3.6+ web server and web framework that’s written to go fast. It allows the usage of the async/await syntax added in Python 3.5, which makes your code non-blocking and speedy.
+
+The goal of the project is to provide a simple way to get up and running a highly performant HTTP server that is easy to build, to expand, and ultimately to scale. </longdescription>
+ <upstream>
+ <remote-id type="github">huge-success/sanic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sanic/sanic-19.12.2.ebuild b/dev-python/sanic/sanic-19.12.2.ebuild
new file mode 100644
index 000000000..a9e22ccf1
--- /dev/null
+++ b/dev-python/sanic/sanic-19.12.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Async Python 3.6+ web server/framework | Build fast. Run fast."
+HOMEPAGE="
+ https://pypi.python.org/pypi/sanic
+ https://github.com/huge-success/sanic
+"
+SRC_URI="https://github.com/huge-success/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ ~dev-python/httpx-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/httptools-0.0.10[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ <dev-python/multidict-5.0[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ >=dev-python/websockets-7.0[${PYTHON_USEDEP}]
+ <dev-python/websockets-9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/httpcore[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-benchmark[${PYTHON_USEDEP}]
+ dev-python/pytest-sanic[${PYTHON_USEDEP}]
+ dev-python/pytest-sugar[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/docutils \
+ dev-python/pygments \
+ ">=dev-python/sphinx-2.1.2" \
+ dev-python/sphinx_rtd_theme \
+ ">=dev-python/recommonmark-0.5.0"