aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Fox <flewkey@2a03.party>2021-11-30 14:11:26 -0800
committerRyan Fox <flewkey@2a03.party>2021-11-30 14:11:26 -0800
commitaf60ecc6910596728251cb01f1c644ed18f687db (patch)
tree0e9321b1d095197e67f2d377c8e36ed188f6c2be
parentapp-admin/chezmoi: Bump to v2.9.0 (diff)
downloadguru-af60ecc6.tar.gz
guru-af60ecc6.tar.bz2
guru-af60ecc6.zip
gui-apps/foot: Bump to 1.10.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Ryan Fox <flewkey@2a03.party>
-rw-r--r--gui-apps/foot/Manifest1
-rw-r--r--gui-apps/foot/foot-1.10.1.ebuild60
-rw-r--r--gui-apps/foot/foot-9999.ebuild5
-rw-r--r--gui-apps/foot/metadata.xml1
4 files changed, 65 insertions, 2 deletions
diff --git a/gui-apps/foot/Manifest b/gui-apps/foot/Manifest
index b0a5ee6ae..bc3063886 100644
--- a/gui-apps/foot/Manifest
+++ b/gui-apps/foot/Manifest
@@ -1,4 +1,5 @@
DIST foot-1.10.0.tar.gz 442267 BLAKE2B 3038b25a51c1084f5b80bb12a393b53f9c8036654a665d3ca06ca2b918a2152d27db523b5fa10f3c509a32dca9f95492d42cada6b76131cd23f84ec7b88dae0c SHA512 8578eaee5d6889cc2d76c09cb58b1848bd35064c82d18af46237cc3fe4b5d0b7f4236ee51ef6c91105910e85fb8739919b6f8b10016ae1bd5c642c85634be1e8
+DIST foot-1.10.1.tar.gz 443696 BLAKE2B 320d7d574a186cbbac4e5e3cde04164adee6a98e30b370045ea6576747a5ef3d721c20fa08c421a677be232e6a867941e6120ba561c9f1e893e332412ccbc0ab SHA512 26355a7a0bcf2f5ec0e7fb844fccda48bc04b31adae76a84c2513b9ba45e2fd22e9cdf64fa4d322952a56ec6d5ed38bbd39d86fade5f29d960a81737f9a984fc
DIST foot-1.7.1.tar.gz 390533 BLAKE2B 5eac8041ac5f46b71d8037550bcdd14899071e63fc4a9c6eabe2c44d336e3339e7dbf8b487ff79aa09a6f73378d1faca140fedbf864fdf641a0706c0b9c7912a SHA512 fa6961b24ef7929378c796a77547f509bc2ff319b3b546be8fad31dd02f2686771d2d4a0c72792746e004052fc032f180eb716cb45e2ebbf549859f1b7de7420
DIST foot-1.7.2.tar.gz 392748 BLAKE2B effd72665c553fbf3687fdb17776b264a775311503d974d12b5de4f4b7d1b835755824781a345f29f4866a33f449c61990830452bdca101952ff8c490e37b5f2 SHA512 2acb46daca5840b3a9fb0fc7055f9234618d7d6884ce74fee382f3904136a85f5c17f7119449fd7943dba2ccce2dde9a62d13a1b363ee234765b6ab65d95e19b
DIST foot-1.8.0.tar.gz 415924 BLAKE2B ec97a6b76f568770fd9011e2245aee9b96c8fc51fb11f022ce7cc8a40bae81d45172e5e435aeab4575a8123825481fe3537376ac700f7036ea4e7079a0844eac SHA512 eb0e0c1b29490f60b241259819bb2e7ab4b847e1d5a1fe70a31e893d8588e82f04f184d88a91e77222aba6fb9473f10e20461278535b6de4c2f3345440354583
diff --git a/gui-apps/foot/foot-1.10.1.ebuild b/gui-apps/foot/foot-1.10.1.ebuild
new file mode 100644
index 000000000..4c91677f7
--- /dev/null
+++ b/gui-apps/foot/foot-1.10.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/foot.git"
+fi
+
+DESCRIPTION="A fast, lightweight and minimalistic Wayland terminal emulator"
+HOMEPAGE="https://codeberg.org/dnkl/foot"
+LICENSE="MIT"
+SLOT="0"
+IUSE="ime +themes +grapheme-clustering"
+
+DEPEND="
+ dev-libs/libutf8proc
+ dev-libs/wayland
+ media-libs/fcft
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ >=sys-libs/ncurses-6.3
+ gui-apps/foot-terminfo
+ )
+"
+BDEPEND="
+ app-text/scdoc
+ dev-libs/tllist
+ dev-libs/wayland-protocols
+ sys-libs/ncurses
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ime)
+ $(meson_use themes)
+ $(meson_feature grapheme-clustering)
+ "-Dterminfo=disabled"
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die
+}
diff --git a/gui-apps/foot/foot-9999.ebuild b/gui-apps/foot/foot-9999.ebuild
index e455c6e12..4c91677f7 100644
--- a/gui-apps/foot/foot-9999.ebuild
+++ b/gui-apps/foot/foot-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit meson xdg
@@ -18,7 +18,7 @@ DESCRIPTION="A fast, lightweight and minimalistic Wayland terminal emulator"
HOMEPAGE="https://codeberg.org/dnkl/foot"
LICENSE="MIT"
SLOT="0"
-IUSE="ime +grapheme-clustering"
+IUSE="ime +themes +grapheme-clustering"
DEPEND="
dev-libs/libutf8proc
@@ -46,6 +46,7 @@ BDEPEND="
src_configure() {
local emesonargs=(
$(meson_use ime)
+ $(meson_use themes)
$(meson_feature grapheme-clustering)
"-Dterminfo=disabled"
"-Dwerror=false"
diff --git a/gui-apps/foot/metadata.xml b/gui-apps/foot/metadata.xml
index cb9b06845..1c4b6ed68 100644
--- a/gui-apps/foot/metadata.xml
+++ b/gui-apps/foot/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="ime">Enable IME support</flag>
+ <flag name="themes">Install example theme files</flag>
<flag name="grapheme-clustering">Enable grapheme clustering support</flag>
</use>
</pkgmetadata>