aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-30 19:01:13 +0200
committerGábor Oszkár Dénes <gaboroszkar@protonmail.com>2022-03-30 19:01:13 +0200
commitce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f (patch)
tree16092c6df97528e36abb3a5af9729a8e8d72487a /dev-python/pylatexenc/pylatexenc-2.10.ebuild
parentdev-python/retworkx: new package (diff)
downloadguru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.tar.gz
guru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.tar.bz2
guru-ce2693bc87dd7b0e2f7cc98ddae9fe6c08d4087f.zip
dev-python/pylatexenc: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Gábor Oszkár Dénes <gaboroszkar@protonmail.com>
Diffstat (limited to 'dev-python/pylatexenc/pylatexenc-2.10.ebuild')
-rw-r--r--dev-python/pylatexenc/pylatexenc-2.10.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pylatexenc/pylatexenc-2.10.ebuild b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
new file mode 100644
index 0000000000..dcf1d618c3
--- /dev/null
+++ b/dev-python/pylatexenc/pylatexenc-2.10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple LaTeX parser providing latex-to-unicode and unicode-to-latex conversion"
+HOMEPAGE="https://github.com/phfaist/pylatexenc"
+SRC_URI="https://github.com/phfaist/pylatexenc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest