aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 02:35:56 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-04-25 02:37:18 +0200
commitf89a4bbb7b88b1515a08c33a5da725fc285550ef (patch)
treed5a74e6fcd80939e37c7340047e9ecd11f29aa66 /dev-python/skia-pathops
parentsci-libs/jdqz: longdesc lang="en" (diff)
downloadguru-f89a4bbb7b88b1515a08c33a5da725fc285550ef.tar.gz
guru-f89a4bbb7b88b1515a08c33a5da725fc285550ef.tar.bz2
guru-f89a4bbb7b88b1515a08c33a5da725fc285550ef.zip
dev-python/skia-pathops: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/skia-pathops')
-rw-r--r--dev-python/skia-pathops/Manifest1
-rw-r--r--dev-python/skia-pathops/metadata.xml12
-rw-r--r--dev-python/skia-pathops/skia-pathops-0.4.0.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/skia-pathops/Manifest b/dev-python/skia-pathops/Manifest
new file mode 100644
index 000000000..67aaadb1e
--- /dev/null
+++ b/dev-python/skia-pathops/Manifest
@@ -0,0 +1 @@
+DIST skia-pathops-0.4.0.zip 41254656 BLAKE2B 000829370de58d75cd56211c564c9d58ccf530b638ec0314a8e91fb1a9bb2e3f7e38618f88f3f78f5c404eb9a5d2e182419be7ec411418459e47ad1400bfd615 SHA512 23162a491cbabc1915ef8263c3d49672fb6a2cd4165707fa2e42a43d8e2d4b6ec0ea2e9c2aa377de8e1cbcc1ad6ff7dc8c03b9bd9f6844b97a8a6e538e35075e
diff --git a/dev-python/skia-pathops/metadata.xml b/dev-python/skia-pathops/metadata.xml
new file mode 100644
index 000000000..25c671f4e
--- /dev/null
+++ b/dev-python/skia-pathops/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">fonttools/skia-pathops</remote-id>
+ <remote-id type="pypi">skia-pathops</remote-id>
+ </upstream>
+ <longdescription lang="en">
+Python bindings for the Google Skia library's Path Ops module, performing boolean operations on paths (intersection, union, difference, xor).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild b/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild
new file mode 100644
index 000000000..96d1bc924
--- /dev/null
+++ b/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+KEYWORDS="~amd64"
+DESCRIPTION="Python bindings for the Skia Path Ops"
+HOMEPAGE="
+ https://github.com/fonttools/skia-pathops
+ https://skia.org/dev/present/pathops
+"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ ~media-libs/skia-80:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ dev-python/pytest-randomly[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ app-arch/unzip
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+# dev-python/setuptools_git_ls_files[${PYTHON_USEDEP}]
+
+#S="${WORKDIR}/${PN}-${MY_PV#v}"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ export BUILD_SKIA_FROM_SOURCE=0
+}
+
+python_prepare_all() {
+ sed -e '/doctest-cython/d' -i tox.ini
+ distutils-r1_python_prepare_all
+}